Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I setup a new ubuntu quantal system and edited /etc/default/grub as follows:

# If you change this file, run update-grub afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo
#GRUB_GFXMODE=640x480

# Uncomment if you dont want GRUB to pass "root=UUID=xxx" parameter to Linux
GRUB_DISABLE_LINUX_UUID=false

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_LINUX_RECOVERY=false

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Afterwards I ran update-grub which reported no errors. However /boot/grub/menu.lst still has "quiet splash" in the kernel command line:

title   Ubuntu, kernel 3.5.0-17-generic
uuid    3f26e165-5167-43e5-8fa2-aa55f7919d2a
kernel    /boot/vmlinuz-3.5.0-17-generic root=UUID=3f26e165-5167-43e5-8fa2-aa55f7919d2a ro quiet splash 
initrd    /boot/initrd.img-3.5.0-17-generic
quiet

title   Ubuntu, kernel 3.5.0-17-generic (recovery mode)
uuid    3f26e165-5167-43e5-8fa2-aa55f7919d2a
kernel    /boot/vmlinuz-3.5.0-17-generic root=UUID=3f26e165-5167-43e5-8fa2-aa55f7919d2a ro  single
initrd    /boot/initrd.img-3.5.0-17-generic

How can fix it, so get rid of the "quiet" and "splash" options?

share|improve this question
    
Quantal.. You're brave. –  Tom O'Connor Nov 12 '12 at 11:09
    
Why, it their latest stable version? :) –  gucki Nov 12 '12 at 11:10
    
I guess you need to remove quiet splash manually from the menu.lst/grub2.cfg file. I encountered same issue in Fedora, I guess the update will append other parameters from the previous kernel parameters. –  LiuYan 刘研 Nov 12 '12 at 11:40

1 Answer 1

up vote 1 down vote accepted

Just so you know, 12.10 (and almost most other Ubuntu versions) uses Grub2 and not Grub. One of the major differences between Grub and Grub2 packages is that there is no /boot/grub/menu.lst file and it has been replaced by /boot/grub/grub.cfg.

Your changes to the /etc/default/grub will not update the /boot/grub/menu.lst file and the command update-grub actually only updates the /boot/grub/grub.cfg file.

So, if you would check the /boot/grub/grub.cfg file, you can notice that the kernel command line would no longer have the "quiet splash" in it.

share|improve this answer
    
Grub2 has been used in Ubuntu for quite some time, starting with 9.10, I believe. That's three years now. Editing /etc/default/grub and running update-grub afterwards is the preferred and supported way of managing /boot/grub/grub.cfg, so OP is doing nothing wrong. Also, what's this about "admitting" to use 12.10? Quantal is the current, newly released stable version of Ubuntu. Nothing wrong with using it (although I prefer LTS releases). –  daff Nov 12 '12 at 13:34
    
Until 12.04, grub2 was at version 1.99. From 12.10 onwards, grub2's package version is 2.00. –  jokerdino Nov 12 '12 at 13:37
    
No, it is "Grub2", starting with version 1.98. Legacy Grub ("Grub1") was up to version 0.97 and hasn't been used in Ubuntu for three years now. See help.ubuntu.com/community/Grub2 –  daff Nov 12 '12 at 13:43
    
If you may read the question, OP is confused that menu.lst file is not updated and grub2 never used that file. Anyway, I updated my answer to be less confusing. –  jokerdino Nov 12 '12 at 23:59
    
I just looked at my dpkg and it seems there's grub (0.97-29ubuntu66) installed together with grub-common (2.00-7ubuntu11). I'll remove grub and install grub-pc instead and see if it works the next reboot (I cannot reboot now, it's a server...) –  gucki Nov 13 '12 at 7:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.