Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to get an IPv6 enabled router to forward data from one interface to the other and I'm having issues.

When following this example (http://www.cisco.com/en/US/tech/tk872/technologies_configuration_example09186a0080ba6106.shtml) I am able to get full connectivity between all 3 routers in my simulator. However when I try to use only 1 router; I can't get connectivity to the other interfacs on the same router.

My PC is directly attached to FA 1/0 and it can ping the router's interface. However it can not ping any other interface on the router(which unless I'm missing something it should be able to do). The router on the other hand can ping everything. I thought static routes might help; but the router already has routes for everything.

I'm thinking the packet should come in; router looks up the destination in it's ipv6 routing table and then realizes it's for itself, and should respond. I thought maybe it couldn't respond directly; so I tried pinging a device like 2001:0000:0000:1000::2, but i don't get a response.

I'm running on IOS 12.4.

I'm missing something(hopefully simple), but I just can't see what it is. With only 1 router; how do I enable my PC to talk to the other subnets? Thank you in advance, Robert

Topology:

R1

FA 0/0:
2001:0000:0000:0000::1/52

FA 0/1:
2001:0000:0000:1000::1/52

FA 1/0:
2001:0000:0000:2000::1/52

Loopback 0:
2001:0000:0000:3000::1/52

PC:
2001:0000:0000:2000::2/52

PC plugs directly into FA 1/0 on the router.

--- Configuration ---

ipv6 cef
ipv6 unicast routing

interface Loopback0
 no ip address
 ipv6 address 2001:0000:0000:3000::1/52
 ipv6 enable
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:0000:0000::1/52
 ipv6 enable
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:0000:0000:1000::1/52
 ipv6 enable
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:0000:0000:2000::1/52
 ipv6 enable

--- end of config ---

--- routing table ---

IPV6Lab#show ipv6 route
IPv6 Routing Table - 10 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2

C   2001:0000:0000::/52 [0/0]
     via ::, FastEthernet0/0

L   2001:0000:0000::1/128 [0/0]
     via ::, FastEthernet0/0

C   2001:0000:0000:1000::/52 [0/0]
     via ::, FastEthernet0/1

L   2001:0000:0000:1000::1/128 [0/0]
     via ::, FastEthernet0/1

C   2001:0000:0000:2000::/52 [0/0]
     via ::, FastEthernet1/0

L   2001:0000:0000:2000::1/128 [0/0]
     via ::, FastEthernet1/0

C   2001:0000:0000:3000::/52 [0/0]
     via ::, Loopback0

L   2001:0000:0000:3000::1/128 [0/0]
     via ::, Loopback0

L   FE80::/10 [0/0]
     via ::, Null0

L   FF00::/8 [0/0]
     via ::, Null0

--- end of routing table ---

Edit: Fixed problem description to indicate my Pc is on FA 1/0; not FA 0/1. Thank you for pointing out the error Celada.

share|improve this question
    
I think the problem is the routing table on the PC. Does it have a (default) route for the addresses you are trying to reach? What OS do you run on the PC? –  Sander Steffann Nov 12 '12 at 16:51
    
Windows 7. For IPv6 the default route is Default Gateway 2001:0000:0000:2000::1. My thinking is if the IP is on the same subnet(2000::1), then the router would accept the packet. However if it's not then send it to the default gateway(in this case the router, 2000::1), who will act as the intermediary between the two networks. –  Robert Nov 12 '12 at 16:54
1  
1  
I know you said the default route looks correct but it still kind of looks like an issue on the PC. Try adding ipv6 routing to the Cisco config but I don't think that should be necessary because I think it should be the default. –  Celada Nov 13 '12 at 0:08
1  
I think the problem is that you use Teredo addresses on a LAN interface –  Sander Steffann Nov 13 '12 at 7:49

1 Answer 1

up vote 0 down vote accepted

It seemed to have been a client issue. The above configuration works for me after patching and rebooting my machine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.