Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I login to the console of my Solaris box any command that would normally generate a bell (tab completion with more than one result, pressing an arrow key one too many times, etc) causes the physical system to beep. This is especially obnoxious because the beeps queue so a simple slip up (holding the left arrow too long) can cause it to keep beep for 5-10seconds because each bell needs to be heard.

Is there a simple way to disable this behavior in Solaris? I'm running OmniOS, but I imagine it applies equally to any version of Solaris or other Illumos based distributions (OpenIndiana, Nexenta, etc).

share|improve this question
    
-vb is visible bell (flash) which supresses a beep - check the terminfo database in /usr/share/lib/terminfo for your TERM variable. Not all terminals support this. –  jim mcnamara Nov 17 '12 at 1:04
add comment

1 Answer

This has worked for me (OI 151a7 Intel).
Add this to /etc/system and reboot:

 * Disable system beep: modinfo | grep "beep"
 exclude: pit_beep
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.