Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

suddenly my virtual centos server (5.6 on VMWare-VSphere) is not working... It started with the url not responding, nor the ip. (NO HTTP response, no ping). When I entered on the server via ssh to start troubleshooting I noticed that most of commands don't work anymore:

  • top-> session hangs (it's not slow anyway)
  • ps -> session hangs (funny enough apache server and web app are running and sending me emails)
  • on some directory ls -l -> machine hangs after first line, if ls > l.txt the file show only the first line
  • "more" command, also hangs on some file.

So there are very little things I can try. I recovered my virtual machine from yesterday and before yesterday, and they show the same behaviour, it hangs on commands (but yesterday they were working). There is no firewall on the machine, there is on the host though. I can connect with ftp but I can't download files nor list directory apart the user top directory...

Working hard right now, any idea appreciated

share|improve this question
    
update: a colleague can surf and use the machine perfectly, it seems that it's a network problem with the provider...not fixed yet, but incredibly weird –  Glasnhost Nov 13 '12 at 19:03
    
so it's possible that the previously mentioned commands don't hang the machine, is the answer (like the ls output) that doesn't get through the ssh connection and it's the terminal that "hangs". Now the virtual host provider blames the network connection provider...hmmmm –  Glasnhost Nov 13 '12 at 21:32
    
It is unlikly your machine is hung, you just have severe packet loss caused by the host sending packets too large for your network connection –  Rqomey Nov 15 '12 at 15:07
    
yes, of course, when I understood that it was the ssh session that was hanging and not the processes or the machine, I started to solve the problem...panic doesn't help to think clearly... –  Glasnhost Nov 15 '12 at 16:25

1 Answer 1

up vote 2 down vote accepted

It's a very very long shot here. Make sure your mtu is set correctly across your network. If you are using a VPN it can be 1490 instead of 1500. Run ping to do this: http://gregalbrecht.com/2008/06/10/detecting-mtu/

If it is below 1500 you will have to change settings on your client an host to limit. I won't go into details on how to do this right now as it may not be the problem. Let me know if it is though

share|improve this answer
    
It's a very good shot indeed! I hade the same idea yesterday night and I changed mtu on my PC and started working. Afterward I found out that the netowrk provider changed some router settings and that the hosting provider failed to update something... Good one! –  Glasnhost Nov 14 '12 at 11:05
    
HAHAHA that made my day, actually got asked it in an interview a while back. Glad you got it working –  Rqomey Nov 14 '12 at 11:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.