Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I added

server_tokens off;

to http{} section of /etc/nginx/nginx.conf file and restarted nginx with

service nginx restart

command. but server still publishing the server tokens when responsing to request. I also checked under the sites-enabled/available config files for if is there any server_tokens on, but no there isn't.

share|improve this question
up vote 3 down vote accepted

:)

I finally found the reason. "X-Powered-By" header was added by PHP. so I edited the php.ini to

expose_php = off;

and it's gone. Just "Server: nginx" left and it's not important for me :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.