Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm attempting to troubleshoot an Ubuntu web server which will only respond to requests originated from the local network. I can use the domain name, external IP address, or internal IP address to get to the site, but only from inside the network.

The DNS records are correct on the registrar, they resolve to the correct IP address, the ports are open on the router, and the server is responding just fine to requests from inside the network.

For reference, my config files include the following:

NameVirtualHost *:80
Listen 80

<VirtualHost *:80>
  ...
  <Directory /var/www>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
  </Directory>
</VirtualHost>

The web server is running Ubuntu 12.04 and Apache 2.2.

share|improve this question

closed as off topic by Michael Hampton, Wesley, Shane Madden, Ward, Iain Nov 14 '12 at 8:53

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Are you sure the requests from outside are getting to the web server? Do you have a tcpdump proving it? If it isn't getting to the web server check DNS/firewalls. –  Zoredache Nov 14 '12 at 0:33
    
Didn't know about tcpdump (today's 1 in 10k moment), thanks! –  harbichidian Nov 14 '12 at 1:01
    
@echoback For that matter you can often save yourself the tcpdump if you have access logging enabled on your web server (if you don't see the requests they're obviously not reaching the server - though you'd still want to check with tcpdump from the outside to find out where they're getting lost :-) –  voretaq7 Nov 14 '12 at 1:23

1 Answer 1

As it turns out, there was no problem with Apache itself. Instead, my ISP is blocking traffic to port 80 from anywhere outside my own IP address.

Changing the ports in the NameVirtualHost, Listen, and VirtualHost directives to 8080 and requesting the site worked just fine. Since the router is set up to allow port 80 traffic to the server, the ISP is obviously the culprit.

share|improve this answer

protected by voretaq7 Nov 14 '12 at 2:10

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.