Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

If I try to update from standard Apache to Apache with SNI support with the Plesk installation program (example.com:8447), I get an error, that I have to remove apr-util-ldap-1.4.1-1.el5.x86_64

It's in german:

Informationen über installierte Pakete abrufen... 
Installation started in background
Datei wird heruntergeladen PSA_11.0.9/dist-rpm-CentOS-5-x86_64/build-11.0.9-cos5-x86_64.hdr.gz: 11%..20%..30%..40%..50%..60%..70%..81%..91%..100% fertig.
Datei wird heruntergeladen PSA_11.0.9/update-rpm-CentOS-5-x86_64/update-11.0.9-cos5-x86_64.hdr.gz: 10%..20%..30%..40%..50%..60%..70%..80%..90%..100% fertig.
Datei wird heruntergeladen PSA_11.0.9/thirdparty-rpm-CentOS-5-x86_64/thirdparty-11.0.9-cos5-x86_64.hdr.gz: 10%..26%..43%..77%..100% fertig.
Datei wird heruntergeladen BILLING_11.0.9/thirdparty-rpm-RedHat-all-all/thirdparty-11.0.9-rhall-all.hdr.gz: 100% fertig.
Datei wird heruntergeladen BILLING_11.0.9/update-rpm-RedHat-all-all/update-11.0.9-rhall-all.hdr.gz: 100% fertig.
Datei wird heruntergeladen SITEBUILDER_11.0.10/thirdparty-rpm-RedHat-all-all/thirdparty-11.0.10-rhall-all.hdr.gz: 100% fertig.
Datei wird heruntergeladen SITEBUILDER_11.0.10/dist-rpm-RedHat-all-all/build-11.0.10-rhall-all.hdr.gz: 10%..22%..31%..41%..51%..65%..70%..80%..90%..100% fertig.
Datei wird heruntergeladen SITEBUILDER_11.0.10/update-rpm-RedHat-all-all/update-11.0.10-rhall-all.hdr.gz: 100% fertig.
Datei wird heruntergeladen APACHE_2.2.22/thirdparty-rpm-CentOS-5-x86_64/thirdparty-2.2.22-rh5-x86_64.hdr.gz: 19%..25%..35%..83%..93%..100% fertig.
Datei wird heruntergeladen APACHE_2.2.22/update-rpm-CentOS-5-x86_64/update-2.2.22-rh5-x86_64.hdr.gz: 100% fertig.
Datei wird heruntergeladen BILLING_11.0.9/dist-rpm-RedHat-all-all/build-11.0.9-rhall-all.hdr.gz: 11%..23%..31%..41%..52%..62%..73%..83%..91%..100% fertig.
Datei wird heruntergeladen APACHE_2.2.22/dist-rpm-CentOS-5-x86_64/build-2.2.22-rh5-x86_64.hdr.gz: 36%..50%..100% fertig.
Pakete, die installiert werden müssen, werden ermittelt.
-> Error: Mit der Installation kann erst fortgefahren werden, wenn das Paket apr-util-ldap-1.4.1-1.el5.x86_64 vom System entfernt wird.
Es wurden nicht alle Pakete installiert.
Bitte beheben Sie dieses Problem und versuchen Sie, die Pakete erneut zu installieren.
Wenn Sie das Problem nicht selbst beheben können, wenden Sie sich bitte an den technischen Support.

-> «Error: The installation can be continued only if the package apr-util-ldap-1.4.1-1.el5.x86_64 is removed from the system»

But I can't uninstall apr-util-ldap-1.4.1-1.el5.x86_64 without removing a lot of important packages:

Dependencies Resolved


=========================================================================================================================================
 Package                                 Arch                Version                                        Repository              Size
=========================================================================================================================================
Removing:
 apr-util-ldap                           x86_64              1.4.1-1.el5                                    installed              9.0 k
Removing for dependencies:
 SSHTerm                                 noarch              0.2.2-10.12012310                              installed              4.9 M
 awstats                                 noarch              7.0-11122114.swsoft                            installed              3.5 M
 httpd                                   x86_64              2.2.23-3.el5                                   installed              3.4 M
 mailman                                 x86_64              3:2.1.9-6.el5_6.1                              installed               34 M
 mod-spdy-beta                           x86_64              0.9.3.3-386                                    installed              2.4 M
 mod_perl                                x86_64              2.0.4-6.el5                                    installed              6.8 M
 mod_python                              x86_64              3.2.8-3.1                                      installed              1.2 M
 mod_ssl                                 x86_64              1:2.2.23-3.el5                                 installed              179 k
 perl-Apache-ASP                         x86_64              2.59-0.93298                                   installed              543 k
 php53                                   x86_64              5.3.3-13.el5_8                                 installed              3.4 M
 php53-sqlite2                           x86_64              5.3.2-11041315                                 installed              366 k
 plesk-core                              x86_64              11.0.9-cos5.build110120608.16                  installed               79 M
 plesk-l10n                              noarch              11.0.9-cos5.build110120827.16                  installed               21 M
 pp-sitebuilder                          noarch              11.0.10-38572.12072100                         installed              181 M
 psa                                     x86_64              11.0.9-cos5.build110120608.16                  installed              473 k
 psa-awstats-configurator                noarch              11.0.9-cos5.build110120606.19                  installed               0.0 
 psa-backup-manager                      x86_64              11.0.9-cos5.build110120608.16                  installed              8.6 M
 psa-backup-manager-vz                   x86_64              11.0.0-cos5.build110120123.10                  installed              1.6 k
 psa-fileserver                          x86_64              11.0.9-cos5.build110120608.16                  installed              364 k
 psa-firewall                            x86_64              11.0.9-cos5.build110120608.16                  installed              550 k
 psa-health-monitor                      noarch              11.0.9-cos5.build110120606.19                  installed              2.3 k
 psa-horde                               noarch              3.3.13-cos5.build110120606.19                  installed               20 M
 psa-hotfix1-9.3.0                       x86_64              9.3.0-cos5.build93100518.16                    installed               23 k
 psa-imp                                 noarch              4.3.11-cos5.build110120606.19                  installed               12 M
 psa-ingo                                noarch              1.2.6-cos5.build110120606.19                   installed              5.1 M
 psa-kronolith                           noarch              2.3.6-cos5.build110120606.19                   installed              6.3 M
 psa-libxml-proxy                        x86_64              2.7.8-0.301910                                 installed              1.2 M
 psa-mailman-configurator                x86_64              11.0.9-cos5.build110120608.16                  installed              5.5 k
 psa-migration-agents                    x86_64              11.0.9-cos5.build110120608.16                  installed              169 k
 psa-migration-manager                   x86_64              11.0.9-cos5.build110120608.16                  installed              1.1 M
 psa-mimp                                noarch              1.1.4-cos5.build110120418.19                   installed              2.9 M
 psa-miva                                x86_64              1:5.06-cos5.build1013111101.14                 installed              4.5 M
 psa-mnemo                               noarch              2.2.5-cos5.build110120606.19                   installed              4.1 M
 psa-mod-fcgid-configurator              x86_64              2.0.0-cos5.build1013111101.14                  installed               0.0 
 psa-mod_aclr2                           x86_64              12021319-9e86c2f                               installed              8.1 k
 psa-mod_fcgid                           x86_64              2.3.6-12050315                                 installed              222 k
 psa-mod_rpaf                            x86_64              0.6-12021310                                   installed              7.7 k
 psa-passwd                              noarch              3.1.3-cos5.build1013111101.14                  installed              3.7 M
 psa-php53-configurator                  x86_64              1.6.2-cos5.build110120608.16                   installed              6.4 k
 psa-rubyrails-configurator              x86_64              1.1.6-cos5.build1013111101.14                  installed               0.0 
 psa-spamassassin                        x86_64              11.0.9-cos5.build110120608.16                  installed              167 k
 psa-turba                               noarch              2.3.6-cos5.build110120606.19                   installed              6.1 M
 psa-updates                             noarch              11.0.9-cos5.build110120704.10                  installed               0.0 
 psa-vhost                               noarch              11.0.9-cos5.build110120606.19                  installed              160 k
 psa-vpn                                 x86_64              11.0.9-cos5.build110120608.16                  installed              1.9 M
 psa-watchdog                            x86_64              11.0.9-cos5.build110120608.16                  installed              2.9 M
 webalizer                               x86_64              2.01_10-30.1                                   installed              259 k

Transaction Summary
=========================================================================================================================================
Remove       48 Package(s)
Reinstall     0 Package(s)
Downgrade     0 Package(s)

What should I do?

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

Sorry for answering my own question.

My ISP was able to help me. To get it work, they purged these packages:

mod_ssl-2.2.23-3.el5
apr-util-ldap-1.4.1-1.el5
httpd-tools-2.2.23-3.el5
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.