Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I created a fixed VHD size 800GB. However, when I try to install CentOS 6 x64 bits OS, it only use 127GB LVM volume. How to install CentOS 6 without using LVM? I want to use all the 800GB disk. Thanks.

share|improve this question
When you go through the installation, just select the option to manually configure the disk. It's been a while, but go through and remove the suggested partitioning and put in your own scheme without LVM. – cjc Nov 16 '12 at 18:33
I tried this, use custom partition layer, delete all partitions, it still shows one hard drive sda with 130558MB space. This VHD is 800GB. – garconcn Nov 16 '12 at 23:22
Your subject line is misleading. The problem is not LVM, the problem is that for some reason CentOS isn't seeing the entire 800GB disk or that it's not configured properly on Hyper-V. After the Anaconda is started, flip to a virtual console with a shell and run 'fdisk -l /dev/sda' and report back what it says. – EmmEff Nov 18 '12 at 2:35
Thanks. I updated the subject line. – garconcn Nov 21 '12 at 23:00
up vote 2 down vote accepted

You might be presenting your VHD to your VM as an IDE emulated device. I'd suggest you try showing it as SCSI devices or update your Hyper-V setup. I know a bug was filled at least 1.5 years ago about that - I don't know if there's a fix available though. I don't use Hyper-V much.

Without getting too much into details: your virtual IDE disks present itself as an 'ATA-0' device (version 0). This device would supposedly not support LBA48 addressing. System then fallback to 28-bits addressing, showing a limit around 137GB.

Sorry, this isn't really 'clean' answer, but at least you know the issue.

share|improve this answer
I found the article in Microsoft site and tried using SCSI, it didn't solve my problem, but I guess this might be the problem. Thanks.… – garconcn Nov 21 '12 at 23:01

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.