Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I'm trying to connect to my database, I need to provide the instance name like so:\SQLEXPRESS

I'd like to be able to just connect to my database without having to type the instance name, like so:

How can I accomplish this? I'm using SQL Server 2008 Express R2

share|improve this question

That's not a server name, it's an instance name, and it's necessary, as there may be several SQL instances running on a single server.

share|improve this answer
Sorry, I meant instance name. What I want to do is set a default instance but the only way I know to do this is to do a complete reinstallation of SQL Server 2008. I was hoping for a better solution. – l46kok Nov 14 '12 at 6:38

You cannot change the default instance for a host. The default instance is always the "unnamed instance".

You can fiddle with things on the client side of the connection by setting up an alias. See this ServerFault answer. This solution works fine in a development or testing environment, or if you have a small number of computers connecting to a production database. If you have a large number of computers connecting to the database, getting the configuration right on each computer can be onerous without some sort of automation/scripting.

share|improve this answer

As I see it, you have two options:

1) Reinstall SQL Express and choose the option to name the instance. Choose the Default Instance option, or type in MSSQLSERVER (which is the default instance's real name).

2) Connect into the instance on its assigned port number. Each SQL instance is assigned a dynamic port number, so you should set a static port number for the instance in SQL Server Configuration Manager. Then connect to it via a connection string like;1443

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.