Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am really trying to get my home web server up and I don't seem to be succeeding. My web server withing my host system is running my web application and is viewable at the current isp ip 88.89.190.171 over WAN indicating that the webapp is fine and that router ports are forwarded.

I have set up a DNS on this system with a single name server in the network and I manage to ping it with ping ns.thejarbar.org I have registered this private name server at my current hosting provider. My domain (thejarbar.org) is obviously registered and I have pointed it to my name server. My question here is if it is simply a matter of waiting on propagation for me to be able to ping my domain? Another way of asking this is if the fact that my name server is discoverable indicates that I have set it up correctly to be used?

I have tested with dig and dig -x on my host and have A records for the name server. The server is not the Authorative server so I am concerned that this may be the reason why my site is not discoverable. Is there anything else I may need to so still? I only have one ns. currently, but should this succeed I will be purchasing a more stable secondary system to host my development applications. This is my best chance at getting work (freelance development) due to illness) and this I feel is the last step I need to succeed.

Please note that this is temporarily a home server and I will most likely be using it as part of a professional setup very soon I will likely have to repeat this question therefore in a prefessional context in a few weeks as nothing will be different other than the fact that I am going to have a server running elsewhere.

I am using bind9 and Ubuntu 12.10 and my records are:

$TTL 3D
@ IN SOA ns.thejarbar.org. email. (
 13112012
 28800
 3600
 604800
 38400
);
thejarbar.org.            IN      A         10.0.0.42
@            IN      NS        ns.thejarbar,org.
yuccalaptop  IN      A          10.0.0.19
ns           IN      A                    10.0.0.42
gw           IN      A                    10.0.0.138
www          IN      CNAME                thejarbar.org.

$TTL 3D
0.0.10.in-addr.arpa. IN SOA ns.thejarbar.org. email. (
   13112012
   28800
   3600
   604800
   38400
);

0.0.10.in-addr.arpa.       IN      NS      ns.thejarbar.org.

42   IN      PTR     thejarbar.org.
19   IN      PTR     yuccalaptop.thejarbar.org.
138   IN      PTR     gw.thejarbar.org.

My localhost IP is 10.0.0.42 I wish for this to be my host and name server.

share|improve this question
    
Sure I will update the question and thank you. My domain is thejarbar.org –  thejartender Nov 14 '12 at 12:27
1  
I must warn you, though, that home systems are explicitly, line one, bold text, off-topic for SF, and your question may get closed as a result. I would have voted to close it myself if not for the fact that it's well-written and you've clearly put some thought into your diagnostics before posting. That still (sadly) doesn't make it an on-topic question. –  MadHatter Nov 14 '12 at 12:30
    
Thank you again I updated my question. I mentioned this as a home server purely because it is at home. It will be used professionally within weeks though. I updated my question, but I notice a relevant answer that has been posted my be my solution. :) –  thejartender Nov 14 '12 at 12:46

2 Answers 2

up vote 4 down vote accepted

OK, the whois confirms that the listed nameserver for thejarbar.org is 88.89.190.171, as you had said, but there doesn't appear to be any nameserver running on that host, or at least there isn't one that's prepared to accept queries for your domain:

[madhatta@risby ~]$ dig thejarbar.org @88.89.190.171

; <<>> DiG 9.8.4-RedHat-9.8.4-2.fc16 <<>> thejarbar.org @88.89.190.171
;; global options: +cmd
;; connection timed out; no servers could be reached

Until you fix that, nothing's going to work, because your domain DNS is inoperative.

Edit: OK, I see you fixed the DNS; well done!

[madhatta@risby gatekeeper-technology]$ dig thejarbar.org @88.89.190.171
[...]
;; ANSWER SECTION:
thejarbar.org.      259200  IN  A   10.0.0.42

That's not going to help anyone outside, because that's an unroutable RFC1918 address. You need to serve 88.89.190.171 as your A record if you want external people to be able to access this site. Note that that will very likely stop access working on your internal network; the solution to that is split-horizon DNS, so that outside your network people get the public address, and inside people get the private one. Configuring your BIND to do split-horizon DNS is not something that can be easily answered here, but there are a lot of tutorials out there if you google.

Edit 2: you're still propagating private IP addresses, one of them being for your nameserver:

[madhatta@risby scratch]$ dig thejarbar.org @88.89.190.171
;; ANSWER SECTION:
thejarbar.org.      10800   IN  A   88.89.190.171
;; AUTHORITY SECTION:
thejarbar.org.      10800   IN  NS  ns.thejarbar.org.
;; ADDITIONAL SECTION:
ns.thejarbar.org.   10800   IN  A   10.0.0.42

Note that bottom line. This will not make the DNS work well, since it poisons everyone's cache each time they look up your site.

share|improve this answer
    
Thank you so much –  thejartender Nov 14 '12 at 17:24
    
I did as suggested, using my ISP IP as my A record value. It does not seem to work. Is this because I set a TTL value of 3D meaning I must wait 3 days for a refresh of my SOA across all zones? If so I must be a little more lenient with these values while testing. How do I map my ISP IP in reverse? Is this tool (ipchecking.com/?ip=88.89.190.171&check=Lookup) credible. You have aided me greatly in that I have confidence that I can request a static IP and purchase an additional server for hosting my production applications :) –  thejartender Nov 15 '12 at 8:59
    
Hatter Thank you. I thought you meant only the domain A record and thus ignored the nameserver –  thejartender Nov 17 '12 at 16:36

You need to port forward UDP/TCP port 53 to your name server in order for it to recieve and answer DNS queries for your domain.

share|improve this answer
    
Glad to help... –  joeqwerty Nov 15 '12 at 17:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.