Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a problem with my default IPv6 route not coming up after boot on a Debian Squeeze system. This is my config (/etc/network/interfaces):

# Loopback device:
auto lo
iface lo inet loopback
iface lo inet6 loopback

# device: br0
auto  br0
iface br0 inet static
  bridge_ports eth0
  bridge_fd    0
  address      88.198.62.xx
  broadcast    88.198.62.63
  netmask      255.255.255.224
  gateway      88.198.62.33
  up route add -net 88.198.62.32 netmask 255.255.255.224 gw 88.198.62.33 br0

iface br0 inet6 static
  address      2a01:4f8:131:10x::2
  netmask      64
  gateway      2a01:4f8:131:100::1
  up route -A inet6 add 2a01:4f8:131:100::1/59 dev br0

My inet comes up alright, but I have to exec the route command manually after boot to make IPv6 work. Otherwise I can't even reach my gateway.

This is the output of ip -6 route show after boot:

2a01:4f8:131:10x::/64 dev br0  proto kernel  metric 256  mtu 1500 advmss 1440 hoplimit 4294967295
unreachable fe80::/64 dev lo  proto kernel  metric 256  error -101 mtu 16436 advmss 16376 hoplimit 4294967295
fe80::/64 dev br0  proto kernel  metric 256  mtu 1500 advmss 1440 hoplimit 4294967295
fe80::/64 dev eth0  proto kernel  metric 256  mtu 1500 advmss 1440 hoplimit 4294967295

I already tried it with:

up ip -6 route add 2a01:4f8:131:100::1 dev br0
up ip -6 route add default via 2a01:4f8:131:100::1 dev br0

in /etc/network/interfaces, but with the same results. If I execute those commands manually on my shell, everything starts working nicely. And yes, I tried with post-up instead of up, too.

Only other changes I made was to activate ip forwarding for IPv6, because I want to run some LXC containers on that system.

share|improve this question
1  
2a01:4f8:131:10x::2 is not a valid address. 'x' is not a hexadecimal character. It has to be 0 to make your config work... –  Sander Steffann Nov 14 '12 at 18:58
1  
I know. I added x's to my v4 address also. Thought it would be clear I tried to obfuscate the addresses. ;) I solved the problem. It has something to do with the v6 setup of my ISP. The routes per se were right. But they and the gateway weren't neccessary. –  Georg Bretschneider Jan 14 '13 at 15:31
    
Please post your answer, then, so that others who are stuck with Hetzner may benefit from it. –  Michael Hampton Jun 26 '13 at 2:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.