Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

1.3.8-10 Rkhunter, Ubuntu 12.04.1

I have a strange problem with rkhunter. I haven't found anything helpful after googling extensively... for days.

If I run rkhunter from crontab I'll get a bunch of "Unable to find XXXX" warnings. This is true even after running rkhunter --propupd from the command line.

Here's the weird bit. If I run rkhunter --propupd from crontab I only get one of those "Unable to find" messages and that is for ifconfig.

When I run --propupd from crontab it updates for 106 files, from command line it updates 136 lines. Strange, eh?

Does this have something to do with apparmor? If so, do you have any apparmor config hints for me, I'm a newbie at Apparmor.

Thanks much!

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.