Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a service that is used for converting MS Word documents to PDF's. This service has worked well on some systems yet been unresponsive on others.

The service starts an executable (which has been verified to be running through Task Manager).
Then when I try to use the software to convert documents it fails.

One thing that I noticed is that when I try to stop the service there is no error, but the executable is still running (whereas on systems are working, the executable will also stop).

Then when I try to restart the service I get a failure message saying ------

"Error 1053: The service did not respond to the start or control request in a timely fashion".

When I kill the executable in Task Manager then start the service, the executable is started and it appears to run correctly again.

I have this service running as the local administrator for the machine. I have also tried installing this in a different folder besides for Program Files, but I will still get the same problem.

Has anyone had any issues like this before?

share|improve this question
    
have a look in event viewer and paste it here. –  Sc0rian Nov 14 '12 at 21:56
    
Every time I start the service I receive 3 events: 1st) Error- A timeout was reached (30000 milliseconds) while waiting for the DocumentService service to connect 2nd) Error- The DocumentService service failed to start due to the following error: The service did not respond to the start or control request in a timely fashion. 3rd) Info- The DocumentService service entered the running state. –  OrangeGrover Nov 15 '12 at 0:24
    
When I run the executable manually without starting the service, everything works just fine, but when the service starts the executable the executable seems unresponsive. –  OrangeGrover Nov 15 '12 at 18:00

1 Answer 1

up vote 0 down vote accepted

The solution to this was very obscure : http://social.msdn.microsoft.com/Forums/en/innovateonoffice/thread/b81a3c4e-62db-488b-af06-44421818ef91

Basically, in Server 2008, this Desktop folder is no longer created by default, so you must create it manually: For 64-bit create: C:\Windows\SysWOW64\config\systemprofile\Desktop

For 32-bit create: C:\Windows\System32\config\systemprofile\Desktop

Sometimes, the executable still doesn't stop when the service is stopped, but the service does work now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.