Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have this line in fstab:

/dev/sda3  /  ext3  defaults  1  2

I supposed I should change it to:

/dev/sda3  /  ext3  defaults,acl  1  2

I also suppose I should run:

mount -t ext3 -o acl /dev/sda3 /

Oh, but I get an error that it's already mounted or "/" is busy. How do I do this without crashing the system?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

You can pass the remount option to the mount command, for instance:

mount -o remount /

This will cause it to re-read /etc/fstab and apply your new options.

share|improve this answer
    
this will not make the system unusable? will it kick me out of ssh connection? –  Buttle Butkus Nov 15 '12 at 3:29
    
No and no. This is very basic stuff here. –  Michael Hampton Nov 15 '12 at 3:33
    
Yes, I'm sure it is. I've messed with some mounting stuff in the past but spend most of my time on programming. I have no idea what is actually going on when a filesystem is unmounted, but it sounds potentially disastrous. Just ran your command and now testing to see if my acl is working finally. –  Buttle Butkus Nov 15 '12 at 3:35
    
It's working! Thank you. –  Buttle Butkus Nov 15 '12 at 6:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.