Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying cmd --> MMC --> Server Manager and then connecting to my Server 2012 no GUI

but i keep getting the following error The WinRM client cannot process the request

I am unable to upload images right now

This is not related to other post "How to Remote Manage Windows Server 2012 in Server Manager?" because title and description of that post is quite different from what i am asking

share|improve this question
1  
Maybe this helps you: petri.co.il/2008-r2-server-core-enable-remote-management.htm –  Manuel Faux Nov 15 '12 at 19:35
    
@ManuelFaux Thanks for the link but still no joy, i did followed the following msdn link mentioned by Glenn Sullivan unlike 2008 R2 there's no firewall option in sconfig in 2012 but i did disabled my firewall already and i am still getting the same error message Also I am able to open other thing using a remove mmc > like Windows Firewall, Computer Management etc but not server manager. –  hpsoftware Nov 15 '12 at 20:31
    
i update the title of the post saying server 2012 no gui –  hpsoftware Nov 15 '12 at 20:32
1  
Microsoft calls this installation option "Server Core". –  Manuel Faux Nov 15 '12 at 20:39
    
yes you are right, saying no gui makes it easy to distinguish –  hpsoftware Nov 15 '12 at 21:00
add comment

2 Answers

up vote 3 down vote accepted

On the server core (server without GUI you are trying to access remotely), do:
Configure-SMRemoting.exe –Enable " in PowerShell, and
winrm qc in an Admin CMD Prompt.

Note this is assuming that you are accessing Server Manager running RSAT on Windows 8 or using another Windows Server 2012 (non-core) server manager.

Source: http://technet.microsoft.com/en-us/library/jj574205.aspx#BKMK_1_5

share|improve this answer
    
Thanks you pointed me in right direction –  hpsoftware Nov 15 '12 at 21:51
    
now i am getting WinRM Negotiate authentication error need to investigate more on that –  hpsoftware Nov 15 '12 at 21:52
    
I wish i can give Up arrow point to this post but i am new user so not allowed , instead of the bottom one because this one was useful than the one below. The bottom answer didn't apply to 2012 –  hpsoftware Nov 15 '12 at 22:04
    
Finally able to vote up. –  hpsoftware Nov 15 '12 at 23:59
add comment

Have you run sconfig on the server and selected the option to "Allow MMC Remote Management" and "Enable PowerShell?"

This is a good guide: http://blogs.msdn.com/b/virtual_pc_guy/archive/2010/11/11/configuring-remote-management-of-hyper-v-server-in-a-workgroup.aspx

share|improve this answer
    
I did tried this link blogs.msdn.com/b/virtual_pc_guy/archive/2010/11/11/… already but it's old and obsolete Allow MMC Remote Management is not present but i did enabled Configure Remote Management instead and followed the remaining steps and rebooted but no luck Enabled Windows powershell is also missing as i think it's enabled by default –  hpsoftware Nov 15 '12 at 20:22
    
Smells like maybe the firewall is on? –  SpacemanSpiff Nov 15 '12 at 20:33
    
@SpacemanSpiff firewall completely turned off for private public everything i can get to computer management using a remote mmc –  hpsoftware Nov 15 '12 at 20:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.