Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

unrar: error while loading shared libraries: libgcc_s.so.1: cannot open shared object file: No such file or directory

Both rar & unrar are in the /bin folder

I followed this tutorial: http://www.cyberciti.biz/faq/open-rar-file-or-extract-rar-files-under-linux-or-unix/

share|improve this question
    
What distribution are you using? is libgcc installed? –  Shutupsquare Nov 15 '12 at 19:37
    
Which distro are you using and did you install via the package manager or the tarball? (Those are both possible options when following the link you provided.) –  Ladadadada Nov 15 '12 at 19:39
    
I installed it manually as AWS EC2 didn't have the package I was looking for. And I tried reinstalling / installing libgcc both time prior and now resulted in the same error however I'm not very linux savvy so I may have done something wrng –  Stephen Harman Nov 15 '12 at 20:12

1 Answer 1

Chances are, I bet you are running on a 64-bit Linux installation, and you have a 32-bit version of your rar utility. If you are on a Red Hat / Fedora distro, you can yum install libgcc.i686 to install the 32-bit libgcc version. 32-bit libraries go under /lib and /usr/lib, whereas 64-bit ones are under /lib64 and /usr/lib64.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.