Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We are a small team that worked with TRAC + SubVersion, post-commit hooks and all :)

Recently, we have a situation some developers need to work offline, so all together we decided to move to GIT for it is more advanced altogether with the fact it is distributed.

We successfully converted all the repositories of all the project. But unable to integrate GIT repository with its TRAC instance.

1 - set up GIT on a Windows 7 Apache 2.2 server per :

2 - Convert our repositories per :

3 - Set up TRAC with GIT per :

The repository is working can easily Clone/Pull/Push/Commit anything.

When I add the repository to TRAC, I don't see the "Browse Source" and the revision.
when trying to trac-admin <ENV> repository resync "(default)"
I receive the error message: TracError: GIT backend not available

What gives?
Where can I see what's going on?
What am I missing?

share|improve this question
Note: the same trac Env was working with SVN Before – Tomer W Nov 15 '12 at 23:02
up vote 1 down vote accepted


  1. setting TRAC Log to DEBUG showed that TRAC Searched for GIT in c:\usr\bin\git which is definitely wrong, and a result of the UNIX defaults.

this caused failure in execution of --version and such.

  1. setting `[git] git_bin=c:\program files (x86)\git\bin\git.exe Solved the situation.

Happy day

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.