Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an issue with my aging (and soon to be replaced) GroupWise 6.5 system. The IMAP service in the GWIA tends to periodically shut down, requiring that I restart the service. When IMAP is down, my end users who use Blackberry BIS cannot send or receive email on their devices.

It's a royal pain to have to restart the IMAP service several times a day. The GWIA logs do not seem to indicate a problem.

I thought I was on to something yesterday. I discovered that the gwia.cfg file located in SYS:SYSTEM was actually from GW 6.0. The gwia.cfg in DOMAIN\WPGATE\GWIA was titled for GW 6.5 when opening the file for editing. I changed the generic placeholder info in the file to match my environment and restarted the gwia. However, it made no difference in performance. The IMAP service shuts down about 30 minutes after the last restart.

I know this version of GW is antiquated. We are in the process of migrating to Google Apps. But, if anyone has an idea that could fix this issue, I and my end user community would be forever grateful!

share|improve this question
    
The IMAP engine on the GWIA in 6.5 is buggy as hell.. Mac clients especially can bring it to it's knees. Have you full patched it to the latest version of 6.5? –  SpacemanSpiff Nov 16 '12 at 4:08

3 Answers 3

Arg. It has been 9 years since I last looked at a GWIA screen, and never with a BIS. There is one TID that looks possible, 10088648, where Notify Link has been tuned to a non-standard value and this breaks things. Beyond that, I'm at a loss.

share|improve this answer
    
Thanks for the tip. We use Hosted NotifyLink, so I don't have hands-on control of how often they poll my server for updates. –  Jeffrey Majette Nov 21 '12 at 17:13

Why are you still running a GroupWise 6.5 system today when you should be at minimum running GroupWise version 8.0.x or the latest version 2012 (12.0.1). You should expect to have issues running such an old messaging system in today's age. If you go to http://wiki.novell.com/index.php/GroupWise_Release_History , you can see how old a messaging system you have. Support for version 6.5 has ended a very long time ago.

The solution is to upgrade to GroupWise 12.0.1 on Linux or Windows servers. It is rock solid on there and is better than Google Apps. Get off of NetWare 6.5 since Novell is trying to get all its customers moved off of that to Linux.

share|improve this answer
    
Seems off topic to suggest strategy as an answer to a technical issue. Upgrading to a new version requires a support contract and licensing upgrades that they are probably looking to avoid. –  SpacemanSpiff Nov 20 '12 at 22:44
    
Correct. I work for a non-profit and we just don't have the funding to afford newer versions of GW. We can get Google Apps for free (or nearly free). –  Jeffrey Majette Nov 21 '12 at 17:10

Late yesterday afternoon I changed the number of threads for IMAP4 connections from the default setting of 10 to 100 in the GWIA object under Gateways in ConsoleOne. Since then, the IMAP service has been up and stable.

I'm hoping this is the solution I've been looking for.

share|improve this answer
    
Sounds like a reasonable approach, watch your load on the console monitor. On decent hardware that's probably fine. –  SpacemanSpiff Nov 20 '12 at 22:45
    
SpacemanSpiff, thanks for an excellent tip. The hardware is a ProLiant ML350 G5 with 8 GB of RAM and 500 GB of disk space. It's in good shape for a 5 year-old server. As of this writing the IMAP service is still up and stable. And, the server load is under 5%. –  Jeffrey Majette Nov 21 '12 at 17:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.