Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Today I lost the ability to see my Windows Server 2008 R2 shares from any of my 3 Windows XP machines in my small office. The 5 Win7 machines haven't been affected (they are still able to browse/access the 2008 server), but none of my WinXP machines can access the 2008R2 server anymore. Yesterday (and for the previous year) everything was working fine. I do not have a domain setup. I can still access Win7 shares from WinXP clients.

Browsing the server logs, I see that the following update was installed last night:

> Installation Ready: The following updates are downloaded and ready for
> installation. This computer is currently scheduled to install these
> updates on ?Thursday, ?November ?15, ?2012 at 3:00 AM: 
> - Security Update for Windows Server 2008 R2 x64 Edition (KB2761226)
> - Security Update for Microsoft .NET Framework 3.5.1 on Windows 7 and Windows Server 2008 R2 SP1 for x64-based Systems (KB2729452)
> - Windows Malicious Software Removal Tool x64 - November 2012 (KB890830)
> - Cumulative Security Update for Internet Explorer 9 for Windows Server 2008 R2 x64 Edition (KB2761451)

It seems likely that something was changed in last night's update, but so far I haven't seen anything on to prove it. I did hear that XP is reaching the end of the road soon. Any ideas?

share|improve this question
Explain what you mean when you say "...lost ability to access...". What kind of error message are you seeing? – Evan Anderson Nov 16 '12 at 1:43
Thanks for asking. My employees initially just lost the ability to read/write to their mapped shared drives. If I type \\servername in the address bar of win explorer I get the error "Windows cannot find '\\servername'. ..." – Knute Knudsen Nov 16 '12 at 1:49

Before you jump to the conclusion that a Windows update is the culprit I'd make sure that you know you've got good name resolution and that a Windows Firewall setting isn't in play.

  • Are clients able to resolve the name "servername" (use ping servername as a good way to test both DNS-based and NetBIOS-based name resolution)?

  • Is the name resolving to the right IP address? (You wouldn't believe how many times I've fought further up in the stack before I realized a DNS name pointed to the wrong address...)

  • Does netstat -a -n on the server computer show that it's listening on TCP ports 139 and/or 445 (depending on whether you've got NetBIOS enabled)?

  • Windows 7 (Vista, actually) removed the TELNET client from the default OS load (a pity, in my opinion). Install it, or use your favorite netcat implementation, and from a client and verify that you can get a TCP connection to the server computer on TCP port 445. If you can't start looking very closely at firewall settings on the server computer.

share|improve this answer
I was unable to ping servername (timed out) from my XP machines, however servername did resolve on Win7 machines to the correct IP address. The server is listening on 139 and 145. I was able to browse the server from XP using its IP address. I noticed that my router was not configured to report a WINS server, so I configured it to report my server's IP address for WINS server and now servername resolves in XP. Not sure why this wasn't a problem before or why Win7 continued to work without it. – Knute Knudsen Nov 16 '12 at 22:52

Have you checked the windows firewall profile settings? Has anything changed there? Try going into Service Manager, Configuration, Windows Firewall. Verify if any profiles are active and if so, what communication is being blocked. We are troubleshooting a similar issue.

share|improve this answer
Thanks for the reply. Firewall Private and Public Profiles are Active. I can't say for sure if anything has changed in the firewall profile settings (I don't know of a way to see what they looked like on 11/14/12). I can say that Inbound Rules are enabled for Network Discovery (both NB-Name-In and NB-Datagram-In) as well as File and Printer Sharing (All NB-*-In). I did configure the DHCP settings in my router last night to report my server's IP address as primary WINS server, which has enabled me to resolve servername from XP. Still not sure why I didn't need that before the 11/15 update. – Knute Knudsen Nov 17 '12 at 0:39

Just got in this morning to our customer having the exact same issues.

All XP/2003 machines could not access any shares on the 2008R2 DC. Did about an hour of testing, pinging, dns, antivirus, firewall troubleshooting etc and we just sat here scratching our heads.

We than discovered the updates that had went in automatically on the 16th, but this is the 27th. 11 days later and the problem suddenly pops its head out?

Uninstalled all updates from the 16th, rebooted 2008 server... everything now works.

Thanks OP.

share|improve this answer
You have worked AROUND your problem blindly, not figured out the cause. Are you also using WINS? If so, for the love of god why? – SpacemanSpiff Nov 27 '12 at 17:03
That certainly supports my hunch that something was added in that update that caused this problem. I personally think rolling back the updates isn't the best approach. Maybe this will be fixed in one of the next updates. – Knute Knudsen Nov 27 '12 at 17:39

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.