Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

So I tried creating a new partition on Fedora 17 using fdisk as follows:

Command (m for help): n
Command action
e extended
p primary partition (1-4)
p
Partition number (1-4): 1
First cylinder (2048-823215039, default 2048):
Using default value 2048
Last cylinder or +size or +sizeM or +sizeK (1-9039, default 9039): +15G

Once this was done,instead of formatting the partition I created, I ran the partprobe command to write the changes to the partition table. On rebooting the computer, it drops to the debug shell and gives me the error as follows:

dracut warning:unable to process initqueue
dracut warning:/dev/disk/by-uuid/vg_mymachine does not exist

dropping to debug shell
dracut:/#

While trying to run fsck on the said partition from the debug shell, it says "etc/fstab not found" and inside /etc I see a fstab.empty file.

Is it now possible to retrieve what I have from the computer? Any help would be appreciated.

Thanks in advance

Edit: I've also tried the following steps for additional troubleshooting:

  1. I tried to boot using the Fedora disk and tried the rescue mode - says no Linux partition detected.

  2. I tried to create an fstab file by combining the entries from blkid and the /etc/mtab file and using the UUIDs from the mtab file - It didn't work. As soon as I rebooted the machine, it promptly dropped me in to the debug shell and the fstab file which i created wansn't there anymore in /etc (part of this solution)

share|improve this question
    
Probably since you used the word PC, this is going to be moved to unix.stackexchange.com . This site is for more server-y questions –  TheLQ Nov 16 '12 at 5:57
    
@TheLQ Per the faq: "If your question is about… Server and Business Workstation operating systems" (emphasis mine) No mention of home-use in OP's question, so I don't feel it's off topic here. Although Unix.SE is an excellent resource as well. –  jscott Nov 17 '12 at 1:32
add comment

1 Answer

up vote 1 down vote accepted

Yes, looks like you wiped out your existing LVM partition schema. If you already had LVM on the disk, why didn't you use the LVM tools such as system-config-lvm?

Your master boot record is expecting to find your LVM volume information and it's not finding, and reporting the error and thus dropping you to the debug prompt to work on the problem.

This is a good time to make sure your backups were recent. You're probably going to need to restore any data that was residing on that disk.

share|improve this answer
    
Thanks for the response. This is a test machine. So there isn't any critical data (so there aren't any backups). Is there any other method by which I can restore the machine? My aim is to try and bring this machine up again without having to re-install the OS –  i.h4d35 Nov 17 '12 at 4:48
    
You can if you have backups of your partition table and can recreate them. Might be possible if you have an install CD and run the rescue mode, but in many ways you're much better off spinning up a new instance. –  Magellan Nov 17 '12 at 5:50
    
Yeah, the rescue mode on the install CD didn't work. It failed to recognize any Linux partitions.Could you guide me to some resources about backing up and restoring Partition tables? –  i.h4d35 Nov 17 '12 at 8:08
    
You've already blown the partition away. Backups are what you do before you blow stuff up. –  Magellan Nov 17 '12 at 17:34
    
LOL, thx for the help Adrian. Gonna spin up a new instance :) Glad to learn from you. –  i.h4d35 Nov 19 '12 at 4:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.