Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I want to exclude some package(s) when choosing to apt-get upgrade. I'm thinking an edit to source.list probably? For example, maybe a package that updates often with minor point releases, or minor issues to attend to manually first. I'm thinking of percona specifically.

libmysqlclient16 libmysqlclient18 percona-server-client 
percona-server-client-5.5 percona-server-common-5.5 percona-server-server 
percona-server-server-5.5

I still want to run apt-get upgrade and have it update everything it finds normally, except what I've asked to be held back or libmysql* and percona* if possible.

Then I'm not sure yet how I'll upgrade these others manually.

share|improve this question

1 Answer 1

up vote 4 down vote accepted

Pinning Packages or Holding.

This should give a good overview of this. I have had to use it on a server to hold back updates and upgrades for MySQL until a content management system was ready.

share|improve this answer
1  
great, I think you led me in the right direction! Found this with some good examples of holding: forums.debian.net/viewtopic.php?t=55178#p319498 –  Poe Nov 16 '12 at 9:03
    
Also, don't forget to reference the man for apt. It actually talks about pinning in there. If you need details let me know. I still have my old pinning that I used for php related things for Karmic. –  vgoff Nov 16 '12 at 9:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.