Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a VM (on oracle vbox) running Fedora17. I've installed asterisk 11 on it from sources. I've followed the wiki for installation ( to the letter.

The ip on the VM machine running fedora is

and I can ping it from the host machine (Ubuntu 12.04), which is at

I've tried registering with ekiga with the following settings:

user: demo-alice@ Password: verysecretpassword registar: but I'm getting an error "transport fail".

Also, while trying to register I'm logged in to the asterisk CLI with verbose level 3 and debug level 4 and nothing appears.

some more relevant data:

I've added the following code to the end of my sip.conf.sample file:



After I changed the sip.conf.sample file, I've created a copy of it and named it sip.conf. then I logged in to the asterisk CLI and typed sip reload.

Then I'm trying to register and ekiga client from my host machine at but it doesn't work and nothing appears on the asterisk CLI while in verbose mode level 3.

BTW, If there is missing information about my question, please don't close it. comment about what you need to know and I'll edit it in to the question. tnx.

share|improve this question
Try enabling SIP debugging (sip set debug on or sip set debug ip 192.168.1.x). –  James Sneeringer Nov 16 '12 at 22:51
Have you confirmed that you can ping the vm from other systems on your network? –  dkwiebe Nov 16 '12 at 23:56
Also, try turning your firewall off on the VM. –  dkwiebe Nov 17 '12 at 0:02
it was indeed the firewall in the VM. used service iptables stop to turn off. Problem solved –  Tom Klino Nov 17 '12 at 0:27

1 Answer 1

up vote 0 down vote accepted

I'll repost my comments as an answer.

Have you confirmed that you can ping the vm from other systems on your network?

Try turning your firewall off on the VM

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.