Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running Debian (Lenny).

When I run this:

curl --ssl

I get this error:

curl: (60) SSL certificate problem: unable to get local issuer certificate
More details here:

curl performs SSL certificate verification by default, using a "bundle"
 of Certificate Authority (CA) public keys (CA certs). If the default
 bundle file isn't adequate, you can specify an alternate file
 using the --cacert option.
If this HTTPS server uses a certificate signed by a CA represented in
 the bundle, the certificate verification probably failed due to a
 problem with the certificate (it might be expired, or the name might
 not match the domain name in the URL).
If you'd like to turn off curl's verification of the certificate, use
 the -k (or --insecure) option.
share|improve this question

closed as too localized by voretaq7 Nov 17 '12 at 3:33

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

There's a link in that error message that tells you to go read something, have you read it? Have you read the rest of the message under that link? Have you taken the actions those two resources instructed you to? (If the answer to that last questions was "yes" you probably wouldn't be getting this error anymore -- if the answer is honestly yes and you're still getting this error tell us which steps you've taken to make it go away, and let me know so I can re-open this question and we'll try to help you out :) – voretaq7 Nov 17 '12 at 3:33
up vote 8 down vote accepted

It might happen because curl can't access valid CA certs bundle. Maybe you just didn't install those, so try this:

apt-get install ca-certificates

If it doesn't help - check CURL_CA_BUNDLE, make sure curl doesn't look for bundle in a wrong place.

share|improve this answer
yep, did both. I think it was the latter that did it. thanks! – celwell Nov 16 '12 at 22:15
Checking the CURL_CA_BUNDLE also worked for me, somehow I had this line in my .profile: export CURL_CA_BUNDLE=~/.ssh/cacert.pem. Maybe I added it a while ago for debugging/development. Removing it fixed my problem. – schmunk Dec 27 '14 at 1:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.