Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

This post is about a Catalyst 4948E switch. I was looking on the download page and realized that there are no "GD" versions available. Are the "ED" versions stable? Even if you change "ED" to "GD" in the URL the IOS images are still the same.

http://www.cisco.com/cisco/software/release.html?mdfid=283027810&flowid=3592&softwareid=280805680&release=15.1.1-SG2&relind=AVAILABLE&rellifecycle=ED&reltype=latest

Is 15.1 as reliable as 15.0?

My devices are currently on the 12.2 train. Is there anything special to upgrade to one of the 15.x trains? Are the configurations compatible.

share|improve this question
1  
You're asking a question that can't be answered. What you can do, though, is read the Cisco documentation carefully, particularly regarding their release cycle. There are branches that are updated less often than others with new features, but they still get security fixes. This is what most people would consider "more stable", but it can vary. –  gparent Nov 16 '12 at 21:24
    
I'm not sure how Cisco's versioning works. The documentation says next to nothing. 15.0 has obviously "been around longer" but that's the extent of it. Cisco does not recommend one or the other for production environments. –  Chris J Nov 16 '12 at 21:27
1  
The documentation says way more than what I said. I'll try to find it for you, but this is not secret information. –  gparent Nov 16 '12 at 21:30
1  
    
Posted as an answer to your question. You question contained more than one actual question and the rest might be better off in a new question, or maybe they've been answered here already. –  gparent Nov 16 '12 at 21:41

2 Answers 2

You can find information about how Cisco does its releases since IOS 15.0 in this Q&A article:

http://www.cisco.com/en/US/prod/collateral/iosswrel/ps8802/ps10587/ps10591/ps10621/qa_c67_561940.html

Essentially the more feature you add to a product, the more likely you are to introduce new bugs, therefore the "most stable" version of IOS would be the one where feature additions are less frequent.

share|improve this answer
    
Thanks. I actually read through that awhile ago. The issue is there are no "Ms" or "Ts". The files I can download are similar to "cat4500e-lanbasek9-mz.151-1.SG2.bin". The 15.0 version is "cat4500e-lanbasek9-mz.150-2.SG6.bin" –  Chris J Nov 16 '12 at 21:42

The GD designation is, unfortunately, mostly a memory - and even when GD code was available it tended to be a year or two behind in (usually critical) features. Even ED vs LD isn't 100% indicative of ideal code versions in all cases.

Bugs can exist in any version. The bugs that involve your particular set of features are the ones you care about. Check out the bug navigator to list the open/fixed issues in the version of code that best fits your requirement. Your Cisco SE / support team should also be in a position to run through a quick bug scrub to see what the prevailing wisdom is as far as best of the latest-and-greatest but ultimately the bug toolkit is the best tool you've got.

As to upgrading from 12.2 - what features would you gain that would be particularly helpful? Some shops I've seen have made the move to be able to support SSH certs or new knobs on routing protocols while others just want to be on a reasonably modern rev just as a maintenance practice. Toward this end you might also want to run through the feature navigator to determine exactly what's changed from version to version.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.