Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a server with a 100 mbps port and connection that I rate limited to 10 mbps/full duplex because I am only paying for a 10 mbps connection and there are steep overage charges. Ever since then, the bandwidth has absolutely plummeted. I turned off autoneg because I otherwise would not be able to limit the rate to 10 from 100 because the network is operating so much faster. I need a way to average 10 mbps on a server with multiple users logging in on that 100 mbps port and connection. Can this be done without having these issues?

share|improve this question
add comment

1 Answer

up vote 7 down vote accepted

You have created a duplex mismatch. Your port is set to 10/Full and your ISP's port is set to 10/Half.

Either set your port to half-duplex (highly undesirable) or contact your ISP and ask them to set their port to 10/Full.

According to Cisco's official training material for their most basic networking certification:

When one device has disabled autonegotiation, and the other device uses autonegotiation, the device using autonegotiation chooses the default duplex setting based on the current speed. The defaults are as follows:

• If the speed is not known, use 10 Mbps, half duplex.

• If the speed is somehow known to be 10 or 100 Mbps, default to use half duplex.

• If the speed is somehow known to be 1000 Mbps, default to use full duplex.

share|improve this answer
    
By the way, I would strongly recommend reading the book that I referenced and getting your CCENT certification (at minimum). Having this foundational knowledge makes all of your real-world networking problems much easier to understand. –  Skyhawk Nov 17 '12 at 17:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.