Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've installed zentyal (zentyal.org)3.0 as a PDC Domain Controller.

domain name is TEST.INT

windows computers are able to join this domain

But i am having a real tough time joining a openindiana(solaris) server to this domain. i followed these guides



but am unsuccessful. upon issuing the command

smbadm join -u aduser TEST.INT

i get the following error

joining TEST.INT....this may take a minute...

failed to join TEST.INT (UNSUCCESSFUL)

on looking at the logs..i see

smbns_ksetpwd:KPASSWD protocol exchange failed (message stream modified)
Failed to set machine password.
smbd: failed joining TEST.INT(UNSUCCESSFUL)

any ideas? what i am doing wrong..

share|improve this question
just as an update i have tried diffrent lm_auth levels..(2-4) sharectl set -p lmauth_level=2 smb but same error –  stackedup Nov 19 '12 at 5:17
Still no luck after some retries it has now joined the domain but i cannot access it from windows machines. when i double click the openindiana server on windows explorer i get a error saying i donot have the permission for this. however i can browse the server with its ip from a non-domain machine. what may be going on? –  stackedup Dec 1 '12 at 12:08

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.