Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

OK so I have been messing around on my development server. It has been a while since I have had my head in linux and I suspect I have broken something.

I have SSH running and that is working fine.

I also have HTTP and I had FTP running also.

Earlier today I decided I wanted to rename the machine so I updated the /etc/hosts file and /etc/sysconfig/network. I also changed the server name in the httpd.conf.

I rebooted the machine and reconnected to SSH fine.

Later I was messing around with the FTP service (trying to tighten up the user security) and when i tried to connect remotely to FTP no joy, it said cannot connect. I thought that was weird but had planned to remove ftp as we will be using github so removed ftp and moved on.

Then I tried to connect to the website but major fail. even connecting to the IP address is failing. I used lynx to connect to the localhost and there was my site so something going on at server level. I thought maybe something up with iptables but I have not changed them but tried adding http but still no joy.

I have a -

Fedora release 17 (Beefy Miracle) NAME=Fedora VERSION="17 (Beefy Miracle)" ID=fedora VERSION_ID=17 PRETTY_NAME="Fedora 17 (Beefy Miracle)" ANSI_COLOR="0;34" CPE_NAME="cpe:/o:fedoraproject:fedora:17" Fedora release 17 (Beefy Miracle) Fedora release 17 (Beefy Miracle)

Linux version 3.3.4-5.fc17.x86_64 (mockbuild@x86-14.phx2.fedoraproject.org) (gcc version 4.7.0 20120504 (Red Hat 4.7.0-4) (GCC) ) #1 SMP Mon May 7 17:29:34 UTC 2012

This is my iptables -L

Chain INPUT (policy ACCEPT) target prot opt source destination
ACCEPT all -- anywhere anywhere state RELATED,ESTABLISHED ACCEPT icmp -- anywhere anywhere
ACCEPT all -- anywhere anywhere
ACCEPT tcp -- anywhere anywhere state NEW tcp dpt:ssh REJECT all -- anywhere anywhere reject-with icmp-host-prohibited

Chain FORWARD (policy ACCEPT) target prot opt source destination
REJECT all -- anywhere anywhere reject-with icmp-host-prohibited

Chain OUTPUT (policy ACCEPT) target prot opt source destination

Like I say I can use SSH no issue but http although running is a no go from a remote computer.

Any ideas?

share|improve this question
    
Could you show us the output of grep -ri Listen /etc/httpd/* –  James Park-Watt Nov 18 '12 at 10:13
    
Hey James,/etc/httpd/conf/httpd.conf:# Listen: Allows you to bind Apache to specific IP addresses and/or /etc/httpd/conf/httpd.conf:# Change this to Listen on specific IP addresses as shown below to /etc/httpd/conf/httpd.conf:#Listen 12.34.56.78:80 /etc/httpd/conf/httpd.conf:Listen 80 Binary file /etc/httpd/modules/mod_cgid.so matches Binary file /etc/httpd/modules/mod_info.so matches Binary file /etc/httpd/modules/mod_proxy_ftp.so matches Binary file /etc/httpd/modules/libphp5.so matches Binary file /etc/httpd/modules/libphp5-zts.so matches –  Dave Nov 18 '12 at 10:14
    
Nothing abnormal there. Is there anything relevant in the apache error log. path is something like /var/log/httpd/error.log –  James Park-Watt Nov 18 '12 at 10:26
    
SSH, telnet all work fine so I think I have either stuff something up when I changed the hostname, messed up iptables without realising or something similar. DNS seems fine, I can ping the IP and the domain name etc –  Dave Nov 18 '12 at 10:27
    
No nothing strange but as mentioned I can connect to the web service using lynx (text based browser) on the server connecting to local host it is only when I try to connect from a remote location it seems to be broken –  Dave Nov 18 '12 at 10:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.