Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

How can I install the 64bit (x86_64) version of MongoDB?

I've specified in the 10gen.repo the 64bit:

baseurl=http://downloads-distro.mongodb.org/repo/redhat/os/x86_64

But when I run:

yum install mongo-10gen mongo-10gen-server

It's the 32bit (see the i686) that it's set to be installed.

Failed to set locale, defaulting to C
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.fdcservers.net
 * epel: mirror.steadfast.net
 * extras: mirror.fdcservers.net
 * rpmforge: mirror.rit.edu
 * updates: mirror.fdcservers.net
10gen                                                                                                                          |  951 B     00:00     
Not using downloaded repomd.xml because it is older than what we have:
  Current   : Tue Oct 30 15:55:02 2012
  Downloaded: Tue Oct 30 15:54:51 2012
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package mongo-10gen.i686 0:2.2.1-mongodb_1 will be installed
---> Package mongo-10gen-server.i686 0:2.2.1-mongodb_1 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

======================================================================================================================================================
 Package                                    Arch                         Version                                  Repository                     Size
======================================================================================================================================================
Installing:
 mongo-10gen                                i686                         2.2.1-mongodb_1                          10gen                          42 M
 mongo-10gen-server                         i686                         2.2.1-mongodb_1                          10gen                         6.5 M

Transaction Summary
======================================================================================================================================================
Install       2 Package(s)

Total download size: 48 M
Installed size: 118 M

I think I know why it want's to install the 32bit version: the first time I've made the 10gen.repo file I had in there the 32bit link specified, and installed the 32bit, which later I've deleted.

Maybe something has been cached. Could someone help me out with this.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Yes, it appears to be a caching issue:

10gen                                                                                                                          |  951 B     00:00     
Not using downloaded repomd.xml because it is older than what we have:
  Current   : Tue Oct 30 15:55:02 2012
  Downloaded: Tue Oct 30 15:54:51 2012

Clear out your yum cache and then try again.

yum clean all
share|improve this answer
    
Working like a charm. Thanks! –  slownage Nov 18 '12 at 17:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.