Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

After making a mistake of upgrading to php 5.4.8 (from dotdeb), every script i run outputs weird junk at the end of the script. There are 2 threads here: one says i should disable php5filter. After doing that apache simply offers me to download scripts instead of serving them ... Another one says there's a problem with gzip. Looks like a stupid bug since it wasn't there before. And there's no explanation on how to fix it. Someone said it's caused by not adding a new line at the end of the file, but i have lots of includes, i don't even know which file should add this new line, not to mention the fact that i don't want to do this, as my editor is set to automatically strip junk like that...

Can someone please help with this issue, cause google doesn't know anything about it (or at least i don't know how to ask the question)?

UPDATE 1: doing a2dismod deflate solves the problem, but i do need this module. UPDATE 2: don't know if this is related, but after this upgrade, every page is sent with transfer-encoding: chunked, but before the upgrade there was no such header and content-encoding was set to "gzip".

share|improve this question

1 Answer 1

Basically if anyone runs into this problem as well, what i've done is replaced apache2filter (which installed on its own) with something that was previously installed. Something along the lines of this helped:

# this will replace apache2filter with libapache2-mod-php5
apt-get install libapache2-mod-php5
/etc/init.d/apache2 restart

So no need to disable gzip or anything, this worked just fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.