Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

i have a 6 port intel server nic. under the settings on ESXi5, i aggregated 4 of the ports.

i have ZFSGuru running on the VM, which is based off of FreeBSD 9, iirc. this VM has two interfaces, an e1000/em0 and a vxmnet2/vxn0.

initially, i did not set link aggregation on my switch, which is an Allied Telesis AT-9924T. things seemed to work alright. just a few minutes ago, i set port trunking (which is what the manual refers to when talking about link aggregation for some reason) on the switch, and set the aggregation on ESXi to "route based on IP hash" (read on another thread that that's what it should be).

well, after creating the trunk group on the switch, the ZFSGuru's interfaces cannot connect to the hosts on the networks, and as a result the hosts on the network cannot connect to it.

oddly enough, the windows 2008r2 VMs i have on the same ESXi5 box have no problems with connections after i created the aggregated ports on the switch.

i have tried accessing in and out of both the em0 and vxn0 links but neither works.

any and all help will be greatly appreciated.

share|improve this question
2  
What is your goal? What are you trying to do? Why do your FreeBSD NICs have two different drivers? –  ewwhite Nov 19 '12 at 14:13
    
to your first two questions, i want to fix the problem. i thought i made that clear an obvious. i'm sorry if i confused you. next, your last question has no impact on the solution. thanks anyways. –  Sameer Sheikh Nov 20 '12 at 10:37
    
My questions do have an impact on the solution. Your NIC drivers on your ZFS system should be using the same driver, if for no other reason than to have some consistency. I would set both to use the Intel e1000 driver, as that's a more conservative choice. What is the purpose of link aggregation in this case? –  ewwhite Nov 21 '12 at 9:54
    
my bad, i should have been more clear. i have only 1 virtual NIC on the system. since this is a home network and not a production one, i don't feel the need to have a separate iSCSI interface. since the ZFSG box has the vmware tools installed, i have the ability to use the vxmnet2 drivers. i used emX as the default drivers, but when it stopped working, i tried the vxnX drivers, thinking that the emX might have some issue with link aggregation. –  Sameer Sheikh Nov 22 '12 at 0:35
    
as for the second question, because i can. as stupid/obnoxious as that sounds, i am experimenting/learning. i have several systems and other devices at home that access a storage server, which is connected to the ZFSG VM though iSCSI - backup server, folder redirection, video streaming, etc. instead of everyone hitting the 1gbit link, i aggregated 4 gigabit links to increase the bandwidth available to offset any reduction in throughput of any one single gigabit workstation link. –  Sameer Sheikh Nov 22 '12 at 0:40
add comment

1 Answer

i don't know if this fixed it, but it's what i did and things started working.

i cleared the config on the AT-9924T, created a new config, rebooted the switch, and well, things seem to work.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.