Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I need to be able to configure SPF rule for my domain. Problem is that I can normally receive all the emails. But when I send to some recipients they receive it as spam. In the mail failure delivery I always see SPF as neutral.

How can I change this settings? I found a Microsoft tool program and I get something like this: v=spf1 a mx mx:mail.code2future.com +all Where do I insert this? I have cPanel Pro 1.0 (RC1)

Thank you

EDIT:

This is the picture:

share|improve this question
    
SPF records go in the DNS for your domain; is your cPanel controlling your DNS or is it managed elsewhere? –  Shane Madden Nov 19 '12 at 16:51
add comment

migrated from superuser.com Nov 19 '12 at 16:48

This question came from our site for computer enthusiasts and power users.

1 Answer

up vote 7 down vote accepted

First, that SPF line is completely useless. The +all on the end means anyone can send e-mail on behalf of your domain, and it should be considered authentic. Further, that SPF record looks wrong in all sorts of ways, though I can't be sure without knowing more about your environment.

Some servers will even hold this against you. On the servers I run, if your SPF doesn't end in "-all" then you get marked as spam because you're too lazy or ignorant to setup a SPF record correctly. Sorry for the terse language, but 2 points for honesty...

So, once you've got a reasonable SPF record, you need to create a new DNS record of the type TXT, with the contents of that SPF record. The "address" of the DNS record should be blank, default, or "@", depending on how you're system works.


Update:
A couple common configurations just to get you started:

  1. You have 1 mail server. It's configured to receive mail for your domain (including the MX record) v=spf1 mx -all
  2. You have 1 "normal" mail server, and a web server that sends e-mail too (notifications or etc) v=spf1 mx ip:1.2.3.4 -all (where the IP address is that of the web server)
  3. You have completely separate inbound and outbound servers. The outbound have A Records. v=spf1 a -all
  4. You're using a hosted e-mail solutions, such as gmail or something your hosting provides.
    v=spf1 include:get.address.from.your.host.com -all
    v=spf1 include:aspmx.googlemail.com -all (for GMail/Google Apps/etc hosted e-mail only)

The Microsoft Sender ID Framework SPF Wizard is an excellent resource for generating records. You do have to read each option carefully; garbage-in garbage-out.

share|improve this answer
2  
I would pay serious attention to what Chris said about using -all. The standard itself, at openspf.org/SPF_Record_Syntax, defines +all as "The domain owner thinks that SPF is useless and/or doesn't care". –  MadHatter Nov 19 '12 at 17:23
    
How can I form such SPF? and where to write that? –  user123_456 Nov 20 '12 at 11:33
    
See update. The record still goes in a TXT DNS entry. –  Chris S Nov 20 '12 at 13:59
    
I have used this solution v=spf1 mx ip:1.2.3.4 -all and now it's working as it should. is this safe solution? –  user123_456 Nov 27 '12 at 11:16
    
Yep, that's good. As long as you didn't literally use "1.2.3.4", and replaced it with the address of your server. –  Chris S Nov 27 '12 at 14:43
show 6 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.