Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

phpinfo says the file location is /etc/php5/fpm/php.ini.

Additional .ini files parsed /etc/php5/fpm/conf.d/curl.ini, /etc/php5/fpm/conf.d/gd.ini, /etc/php5/fpm/conf.d/mcrypt.ini, /etc/php5/fpm/conf.d/mysql.ini, /etc/php5/fpm/conf.d/mysqli.ini, /etc/php5/fpm/conf.d/pdo.ini, /etc/php5/fpm/conf.d/pdo_mysql.ini, /etc/php5/fpm/conf.d/xcache.ini

Looking in them none of them have anything that deals with post_max_filesize or upload_max_filesize.

I edit this in the php.ini file and restart both the nginx and php5-fpm service. The changes do not happen. The files are still edited. I have tried rebooting the computer.

Does NGINX cache this somewhere that I need to delete in order for these changes to be made live?

I have tried php -i | grep ".ini"

and it tells me the path for php.ini is Path => /etc/php5/cli/

The phpinfo() tells me its /etc/php5/fpm/

I have edited both with no luck.

if I do php -i | grep "post_max" it tells me its 20M, phpinfo still says 8M.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Have you tried to put your php.ini under /etc/php5/fpm/php.ini? This is normally the default location that php reads from, if I understand php5-fpm correctly.

share|improve this answer
    
That's where it is located at. The changes to it are not happening. –  Iscariot Nov 20 '12 at 6:44
    
Do you perhaps have logs for php5-fpm? Is there nothing in your error logs? –  Danie Nov 20 '12 at 7:47
    
Nothing useful, just that it was reloaded over and over again when I was trying to fix the problem. –  Iscariot Nov 20 '12 at 11:54
    
There was ntohing in the logs, but I did find serverfault.com/questions/450460/… –  Iscariot Nov 20 '12 at 12:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.