Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I already disabled NLA on the Terminal Service of Windows 2008 server, that now rdesktop connects to the console directly,

But from a Windows 7 client, it still asks me to populate the password prior to logon.

Any ideas?

P.S: mstsc /v:servername /console /admin doesn't work, it still asks for password

share|improve this question
    
Why are you using both switches /console and /admin? /Console is no longer support on W2k8. See more details. Try "mstsc /v:servername /admin" instead. –  Volodymyr Nov 20 '12 at 14:53
    
Why disable NLA in the first place? –  Chris S Nov 20 '12 at 15:03
    
@ChrisS we run RSA SecureID with Terminal Service, if NLA is running, the user would be prompt for password twice, once before connecting to the console; once when login. So, need to get rid of NLA –  warl0ck Nov 20 '12 at 23:48

1 Answer 1

up vote 2 down vote accepted

You may use an .rdp file for the connection, and specify enablecredsspsupport:i:0 in the rdp file.

https://blogs.technet.com/b/mrsnrub/archive/2010/12/16/xp-clients-credssp-sso-connection-broker-and-other-animals.aspx

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.