Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We faced very strange issue with our linux router. We have CentOS 6.3 server with several VLANs on it. Each VLAN interface has two IP, one management IP for ucarp failover checks and one virtual IP to share with second server. You can see schema below:

                                                     [        ]
172.16.0.100 --> 172.16.0.1 [Virtaul IP    VLAN 10 ] [ Router ] [ Virtual IP    VLAN 20 ] 172.16.1.1 --> 172.16.1.[2-4]
                 172.16.0.7 [Management IP VLAN 10 ] [        ] [ Management IP VLAN 20 ] 172.16.1.7

So the problem is that sometimes traffic from one network can't reach ip address from other net from specific diapason 172.16.1.[2-4] (/30 network). All other addresses from vlan20 are ok. It can be fixed with ifdown/ifup vlan20, but it is very very strange and rediculous bihaviour for router. Also from router ping -I 172.16.0.7 172.16.1.2 is ok, but ping -I 172.16.0.1 172.16.1.2 is dead. I can see icmp requests and responses on 172.16.1.2, and I can see them on router, but ping can't get it. Even more ping -I 172.16.0.1 172.16.1.20 is ok.

share|improve this question

1 Answer 1

Check the MAC addresses, in order to be sure there are no duplicates somewhere on the network.

share|improve this answer
    
No duplicates found. And I can see returning traffic on router, but then It disappears some in the kernel. –  user146279 Nov 22 '12 at 7:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.