Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a service, running with the "Network Service" permissions that installed a certificate into the "personal certificate store" for the "Network Service".

For reasons that are beyond the scope of this question, I need to remove that certificate, but using the MMC's "Certificates" snap-in I failed to find that certificate. I tried opening the certificate store for "Service"->"Local machine"->"Service name", but there's nothing there while the service definitely reports that it sees the certificate.

Any idea how do I access that personal certificate store?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Registry editor.

HKEY_USERS\S-1-5-20\Software\Microsoft\SystemCertificates\My

S-1-5-20 is the Network Service account. "My" represents the Personal store.

Delete the entries from there.

Source: http://support.microsoft.com/kb/185059

share|improve this answer
    
Thanks, that worked. –  Guss Nov 22 '12 at 12:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.