Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have been trying to troubleshoot this problem since 20 hours ago, and still can't find a solution.

I brought down (orderly shutdown) a Domain Controller yesterday. No problem at all connecting to it (via RDP).

The Domain Controller is a VM running on top of XenServer 6.0.2.

The problem started after I brought the VM back up. I cannot ping from my computer to the Domain Controller, &vv. However, the Domain Controller can ping to (and be pinged from) the PDC, the Default Gateway, and some other servers.

Since the DC is not the PDC, it's not as critical... but I still wonder what went wrong...

I've even added a Firewall rule to allow any traffic from my computer... still no go. I can't ping to it, and it can't ping to me.

Since it can ping to the PDC, the DG, and (some) other servers, it's not a problem of XenServer's virtual NIC (I think).

What else should I be looking at?


More information:

  • The problematic DC's address:
  • Ping to PDC ( ) : successful
  • Ping to My PC ( ) : FAILED
  • Ping to Default Gateway ( ) : successful
  • Ping to another (non-DC) server ( ) : successful

Note that the problematic DC and My PC are on the same subnet. Yet, pinging to a server on a different subnet works.

Pinging my computer results in an output like this:

Pinging [] with 32 bytes of data:
Reply from Destination host unreachable.
Reply from Destination host unreachable.
Reply from Destination host unreachable.
Reply from Destination host unreachable.

Finally, output of route print:

Interface List
 13...1e a1 17 a3 d9 74 ......Citrix PV Ethernet Adapter #0
  1...........................Software Loopback Interface 1
 11...00 00 00 00 00 00 00 e0 Microsoft ISATAP Adapter
 14...00 00 00 00 00 00 00 e0 Teredo Tunneling Pseudo-Interface

IPv4 Route Table
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
    266         On-link    266         On-link    266         On-link    266         On-link    306         On-link    306         On-link    306         On-link    306         On-link    266         On-link    306         On-link    266
Persistent Routes:
  Network Address          Netmask  Gateway Address  Metric

IPv6 Route Table
Active Routes:
 If Metric Network Destination      Gateway
  1    306 ::1/128                  On-link
 13    266 fe80::/64                On-link
 13    266 fe80::d993:f856:31c6:4cbe/128
  1    306 ff00::/8                 On-link
 13    266 ff00::/8                 On-link
Persistent Routes:
share|improve this question
The default firewall in recent versions of Windows blocks ping, even a "allow everything from IP" might not override other rules blocking a specific protocol. Have you checked other systems can ping the workstation? – Richard Nov 22 '12 at 9:28
Also, check the arp table (arp -a). Is the target machine included? – ramruma Nov 22 '12 at 9:42
@ramruma strange... arp -a does not show the MAC of the target machines... but there are lots of MACs from many other computers. I wonder what's going on... – pepoluan Nov 26 '12 at 3:47
Have you tried to do a command prompt with elevated privileges? Open command prompt "Run as Administrator" Now try Ping. It should work. Don't have the answer why it works with elevated privileges but it does. I'm still looking for that answer. – user273125 Feb 24 at 22:55
First, check routing. Make sure your PC can actually route traffic to the DC. You can confirm this by using something like wireshark. Also try traceroute to ensure the traffic isn't being routed somewhere strange. If traffic isn't making it to the DC then it's likely there's a bad route or access list rule preventing the traffic. (This could be a windows or third party client firewall). I would be most interested to see if the ICMP packets are actually reaching the DC. – blacklight Feb 24 at 23:03

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.