Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Yesterday, after installing Myob Account Edge accounting on my mac mini server, I lost the ability to screen share with it using the vnc protocol (Go menu > connect to server).

When I try to connect, the screensharingd daemon starts on the server (I can ssh into it fine, and use the server admin tool), but it hangs on the connecting to... screen and never connects. If I kill the process, the connecting to.. screen changes and says something like authentication failed, check your password etc. We have tried with the firewall on and off, and it doesn't make any difference.

MYOB has a FileConnect app which is used to enable network connectivity between myob installations and the myob data file. Im thinking this may be what could be causing the problems, but the FileConnect app just won't die. i kill the process and it just spawns again.

So does anyone know what I should check to like, reset the processes used by screensharing or check to see if its enabled? I've tried launchctl unload on the screensharingd daemon, but it hasn't done anything. I can't restart the computer because its hosting a website...

share|improve this question

Unfortunately I can't help you with this problem directly, but I can recommend Mikogo as a much more reliable alternative for screen sharing. It's a quick, free download that allows you to not only screen share, but also switch control of screens between users in the touch of a button. Check it out at and let me know what you think.

If you have any questions please feel free to get in touch.

Spencer Dunfee Mikogo Team

share|improve this answer

Try restarting the screen sharing / VNC service -- SSH into the host and run the following:

sudo launchctl unload /System/Library/LaunchDaemons/  
sudo launchctl load -w /System/Library/LaunchDaemons/
share|improve this answer
Hey, thanks for your response. Unfortunately that didn't work :( – Benno Dec 5 '12 at 3:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.