Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I can't use apt-get to install it cuz the version of my ubuntu is old but i need to use these packages, is there any way to download and install them manually?

thanks.

share|improve this question
    
Don't use old, out of date, unsupported operating systems. –  Michael Hampton Nov 23 '12 at 0:06

1 Answer 1

For the php part, try: Quoting http://code.google.com/p/sabredav/wiki/Installation

" Composer is PHP's next generation awesome package manager. Where PEAR usually installed packages 'system wide', composer is geared towards per-project package and dependency management.

To install composer, use :

curl -s https://getcomposer.org/installer | php

Or have a look at http://

getcomposer.org for some more details. "

For libcurl3: depending on the version of ubuntu you are using you could try to find a source package for libcurl3 from a newer version and build a backport yourself. Or find the source and make an unpacked build. I'd recommend the former though, it will be cleaner adn easier to remove or upgrade.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.