Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

There are many discussions about glibc on CentOS on serverfault but I couldn't find one directly related to these: I have CentOS 5.8 server and I would like to install G-WAN. It requires GLIBC 2.6, I have 2.5 right now.

Does CentOS 5.8 support GLIBC 2.6 or do I have to upgrade to CentOS 6? Is there a documentation about these requirements?

Thanks.

share|improve this question
    
G-WAN worked hard recently to remove this issue, look at this other reply: stackoverflow.com/questions/13559098/… –  Gil Nov 27 '12 at 14:31

1 Answer 1

The discussions you may have seen are correct...
See here, here, here, and here.

You can't change glibc versions on CentOS 5. You'll need an upgrade to a newer version of RHEL/CentOS.

EL6 ships with glibc 2.12:

Name        : glibc                        Relocations: (not relocatable)
Version     : 2.12                              Vendor: CentOS

Of course, upgrading CentOS versions isn't particularly easy...

share|improve this answer
    
Foo. They just make it sound hard so we can charge exorbitant consulting rates for doing it and making it look easy. –  Michael Hampton Nov 23 '12 at 0:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.