Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

guys sorry I'm a newbie to this but I've been following the mod_wsgi configuration tutorial and it's very spotty. In my httpd.conf file I add the virtual host like so:

# 'Main' server configuration
#
# The directives in this section set up the values used by the 'main'
# server, which responds to any requests that aren't handled by a
# <VirtualHost> definition.  These values also provide defaults for
# any <VirtualHost> containers you may define later in the file.
#
# All of these directives may appear inside <VirtualHost> containers,
# in which case these default settings will be overridden for the
# virtual host being defined.
#
<VirtualHost *:80>
    ServerName wsgihost
    DocumentRoot "/Library/WebServer/Documents"

    <Directory "/Library/WebServer/Documents">
    Order allow,deny
    Allow from all
    </Directory>

    WSGIScriptAlias /myapp /Users/KL/modwsgi/env/myapp.wsgi
    <Directory "/Users/KL/modwsgi/env">
    <Files myapp.wsgi>
    Order allow,deny
    Allow from all
    </Files>
    </Directory>
</VirtualHost>

Now, when I also added in my local host the following:

127.0.1.1 wsgihost

but I can't seem to connect. Am I doing something terribly wrong?

share|improve this question
1  
Which tutorial are you following? In what file have you placed that configuration? If you are on MacOS X, have you actually enabled the web server so that it runs, it doesn't run by default? –  Graham Dumpleton Nov 23 '12 at 5:08
    
This is from the Hello Word Quick Configuration about mid_wsgi...Also, I enabled the web server so it does run. It just seems I can't get the .wsgi script to actually run on the local host AND on www.example.com/myapp –  Kevin Nov 27 '12 at 20:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.