Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am having DD-WRT v24-sp2(05/08/11) running on Asus RT n 13 u B1 router,with dhcp on.

But users not able to connect through wifi...its showing obtaining ip address and disconnects there after.

Wired Devices are getting ip address and able to access internet.Wifi was working till yesterday,but all of a sudden it stopped working.

on the ddwrt controlpanel>system information under Wireless Clients mac address of clients that are trying to connect are appearing but soon it disappears. but no such issue with wired clients.

Can any one please help me in fixing this..

Under the Wireless tab :

Received (RX)14146 OK, 70 errors

Transmitted (TX)4186 OK, no error

share|improve this question
    
When you say "disconnects there after", what precisely do you mean? What exactly happens when you try to connect? –  David Schwartz Nov 23 '12 at 17:02
    
How many client devices do you have? –  Volodymyr Nov 23 '12 at 17:09
    
@DavidSchwartz When a client tries to connect,on the client side its showing obtaining ip address,in the mean time on the router status page under wireless clients;its showing their mac-address for a couple of seconds and clearing that. –  Kevin Parker Nov 24 '12 at 4:46
    
@Volodymyr 15 PC which are wired and almost same no of mobile phones,Problem occurs when mobile tries to connect through wifi. –  Kevin Parker Nov 24 '12 at 4:48

1 Answer 1

up vote 2 down vote accepted

Perhaps, as you said, you made no changes on the router, the issue may be due to IP-address exhaustion.

Default Lease Time on DD-WRT is 1440 mins, i.e. 24H.

Try running "ipconfig /release" & "ipconfig /renew" on a client machine with Wi-Fi enabled.

View active IP-address leases on Status tab > LAN tab.

If this is the case, change lease time to a lower value on general page.

share|improve this answer
    
actually all the wireless devices are mobile phones. –  Kevin Parker Nov 24 '12 at 4:49
    
Dont know whether this is the reason,it worked when i changed 1440 mins to 14 mins. –  Kevin Parker Nov 24 '12 at 5:30
    
Problem appeared again...this time changing that variable didnt make any difference. –  Kevin Parker Nov 24 '12 at 14:36
    
Try to restart your router. Leases will be dropped. –  Volodymyr Nov 24 '12 at 15:26
    
unfortunately restarting router also didnt fix... switching router off for couple of minutes solved it for now. –  Kevin Parker Dec 15 '12 at 10:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.