Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've followed some instructions at: http://docs.codehaus.org/display/JETTY/How+to+configure+SSL

I can serve requests over http (http://localhost:8080/ping), but I can't hit (https://locahost:8443). I get (35) Unknown SSL protocol error in connection to localhost:8443 . This doesn't show up in the logs, so I'm unable to figure out what the issue is...

Any help?

I'm running Jetty 7.6, my jetty.xml looks like this:

 <Call name="addConnector">
        <Arg>
            <New class="org.eclipse.jetty.server.nio.SelectChannelConnector">
                <Set name="port">
                    <SystemProperty name="jetty.port" default="8080"/>
                </Set>
                <Set name="maxIdleTime">30000</Set>
                <Set name="Acceptors">2</Set>
            </New>
        </Arg>
    </Call>
<Call name="addConnector">
      <Arg>
       <New class="org.eclipse.jetty.server.ssl.SslSelectChannelConnector">
         <Arg>
           <New class="org.eclipse.jetty.http.ssl.SslContextFactory">
             <Set name="keyStore"><SystemProperty name="jetty.home" default="." />/lib/keystore.ks</Set>
             <Set name="keyStorePassword">...</Set>
             <Set name="keyManagerPassword">...</Set>
             <Set name="trustStore"><SystemProperty name="jetty.home" default="." />/lib/keystore.ks</Set>
             <Set name="trustStorePassword">...</Set>
           </New>
         </Arg>
         <Set name="port">8443</Set>
       </New>
     </Arg>
</Call>
share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.