Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have installed a bitnami mac stack mainly because I require at least PHP 5.4.7 version for my project. However, I have run into an issue with composer. This is the error I get when I run:

php composer.phar install --dev

The error:

Richard-Knops-MacBook-Pro:my-project richardknop$ php composer.phar install --dev
dyld: Library not loaded: /Applications/MAMP/Library/lib/libiconv.2.dylib
  Referenced from: /opt/local/bin/php
  Reason: Incompatible library version: php requires version 8.0.0 or later, but libiconv.2.dylib provides version 7.0.0
Trace/BPT trap
Richard-Knops-MacBook-Pro:my-project richardknop$

How to solve it?

share|improve this question

closed as off topic by EEAA, RobM, Michael Hampton, Tom O'Connor, Magellan Nov 25 '12 at 1:00

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

As the message fairly clearly indicates, you need to upgrade your libiconv to 8.x. http://www.gnu.org/software/libiconv/

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.