Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I enabled Port Security on the switch.

> conf t
> int fa 0/3
> switchport mode access 
> switchport port-security maximum 1
> switchport port-security mac sticky

And to test if this works, i connected a cable to this port and pinged, then the port got blocked as expected.

Now i reconnected the original desktop (the one which was connected before- the one which is suppose to work with this port). and I am unable to ping by connecting to this port.

I think, the port is, and i am not allowed to plug in even the PC (that i am suppose to plugin). So how can i make this work (Bring the port up for the port 0/3 which will work for the mac address i assigned previously)

note: i am using packet tracer

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Check this

switchport port-security violation {shutdown | restrict | protect} 

The default violation policy (what happens when violation is detected) is "shutdown" port. You can try setting this to protect, or you have to manualy reenable the port (no shutdown on the interface).

share|improve this answer
2  
Alternatively, you could use the global command "errdisable recovery cause psecure-violation". This would cause the port to unlock itself after 5 minutes (by default). Of course, if you still have the offending non-secure device plugged in the port will lock itself again =) –  Jason Seemann Nov 26 '12 at 2:48
    
Could anyone tell me the purpose of adding switchport port-security maximum 1 ? (I know that this is not relevant to this post, but i'm curious to know) –  sharon Hwk Nov 26 '12 at 16:57
    
It is the number of allowed macs on that port. If there is a pc connected to the port, then you allow only one mac on that port (that is the default). If there is a switch/hub on that port, you need to allow more then 1 mac (all the macs on the connected switch). –  mulaz Nov 26 '12 at 17:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.