Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm running a PowerDNS 3.1 on a Debian Wheezy Beta 4 system. The zone data is accessed through a PostgreSQL database, the server answers to both IPv4 and IPv6 queries.

If the DNS-Server knows the A record for one of the name servers referenced by NS records on a zone, it automatically return these A records as additional information to the response on an NS query for that zone. Now even if it knows the AAAA record for one of the name servers of the NS records, it currently does never return an AAAA record as additional information.

How can I enable this? Or is there anything I could be doing wrong?

Output of dig @ns.mydomain.tld NS mydomain.tld:

;; QUESTION SECTION:
;mydomain.tld.                      IN      NS

;; ANSWER SECTION:
mydomain.tld.               86400   IN      NS      ns3.nsprovider.de.
mydomain.tld.               86400   IN      NS      ns2.nsprovider.de.
mydomain.tld.               86400   IN      NS      ns.mydomain.tld.
mydomain.tld.               86400   IN      NS      ns.nsprovider.de.

;; ADDITIONAL SECTION:
ns2.nsprovider.de.          86400   IN      A       1.2.3.1
ns.nsprovider.de.           86400   IN      A       1.2.3.2
ns.mydomain.tld.            600     IN      A       192.0.2.194
ns3.nsprovider.de.          86400   IN      A       1.2.3.3

Output of dig @ns.mydomain.tld A ns.mydomain.tld:

;; QUESTION SECTION:
;ns.mydomain.tld.           IN      A

;; ANSWER SECTION:
ns.mydomain.tld.    600     IN      A       192.0.2.194

Output of dig @ns.mydomain.tld AAAA ns.mydomain.tld:

;; QUESTION SECTION:
;ns.mydomain.tld.           IN      AAAA

;; ANSWER SECTION:
ns.mydomain.tld.    86400   IN      AAAA    2001:db8:100:3022:1::3
share|improve this question

2 Answers 2

up vote 1 down vote accepted

Try setting do-ipv6-additional-processing=yes in your pdns.conf.

share|improve this answer
    
This has been made default in PowerDNS as of today (and thus as of the upcoming 3.2 release). –  Habbie Nov 28 '12 at 13:35

Set do-ipv6-additional-processing=yes.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.