Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running both IIS and Apache. I have Apache set to 127.0.0.2 and IIS to 127.0.0.1 so that I can have them both on port 80.

In order to do this, i had to go into netsh and make it so IIS only listens to 127.0.0.1. The problem is that I have Team Foundation Server on IIS on port 8080 and would like to be able to remotely access it. This means that I need to be able to have IIS listen for all IP addresses on only port 8080.

My question: Is there a way to listen/accept all ip addresses for a specific port? It would basically be a *:8080 entry so that I can have all external computers access my TFS.

If push comes to shove, I'll just ask all members who will access my TFS for their address and I can enter them in manually.

The optimal solution would be if I can have IIS listen to all IP addresses period EXCEPT 127.0.0.2. Is there some exclusion list?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

IIS listen on all interfaces by default. Any interface that is already taken will not be listened on.

Just make sure Apache starts before IIS and you should be set. Are you actually using port 8080 in apache as well?

share|improve this answer
    
i'm not using 8080 at all in apache. in fact, the only reason I didn't disable IIS is because TFS is running on it. How could I guarantee that Apache starts before IIS? IIS is integrated into Windows. I already have apache start on windows startup via a key in the registry but IIS always starts first –  David Torrey Nov 26 '12 at 9:01
    
IF you're not using 8080 in apache at all, and never 80 at all in IIS, I don't see the problem. Just make sure to remove all port 80 bindings on all sites in IIS. IIS is started as a service, you could try switching it to "Automatic (delayed start)", but preferrably you should start Apache as a service as well. –  jishi Nov 26 '12 at 9:06
    
ok that works fine. I hadn't realized that it only listens on ports defined by websites. I do have one other question though: how can i configure IIS to accept credential checks when people use a dyndns url? I have dyndns bound to my IP, but when they go to verify credentials they are rejected. If they use my actual IP address the credentials work –  David Torrey Nov 26 '12 at 9:13
    
What kind of credentials check are you using? I don't see why hostname should matter, unless that is some sort of restriction that you can set on the credentials check. –  jishi Nov 26 '12 at 9:53
    
its just the basic windows authentication. my TFS is set up to use local user credentials –  David Torrey Nov 26 '12 at 10:24
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.