Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Im trying to access phpmyadmin on my server as the user root. I type root as the username and blank as the password and its not letting me in. I setup phpmyadmin.conf to only allow access from my IP address, and here is the config.inc.php:

/* Authentication type */
$cfg['Servers'][$i]['auth_type'] = 'cookie';
/* Server parameters */
$cfg['Servers'][$i]['host'] = 'localhost';
$cfg['Servers'][$i]['connect_type'] = 'tcp';
$cfg['Servers'][$i]['compress'] = false;
/* Select mysql if your server does not have mysqli */
$cfg['Servers'][$i]['extension'] = 'mysqli';
$cfg['Servers'][$i]['AllowNoPassword'] = true;
$cfg['Servers'][$i]['AllowNoPasswordRoot'] = true;

I also tried setting auth_type as config, changed the host to my IP Address, and added at one point the following:

$cfg['Servers'][$i]['AllowNoPassword'] = true;
$cfg['Servers'][$i]['AllowNoPasswordRoot'] = true;
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';

Im not quite sure what to do at this point.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

First revert all changes in file you made, you have to simply reset mysql root password for that. Check out this tutorial for resetting mysql root password .

share|improve this answer
    
thanks! worked perfectly! –  Jonathan Kushner Nov 26 '12 at 11:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.