Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to set up a new 5505 for the first time. I am not a network admin, so I'm using the graphical tool that comes with it, ASDM. One of the things I am trying to do is change the subnet used by the "internal" network to 10.0.0.x. In the startup wizard, I change:

  • the internal interface's ip address to
  • the dhcp server to serve ip addresses in
  • allow incoming https/ASDM connections on internal's 10.0.0.x subnet

Then when I click "go" at the end of the wizard, a modal dialog pops up that says "sending command(s) to router" or somesuch. That dialog never goes away. Further, it seems like the configuration never gets applied. I can't renew the DHCP lease on the machine connected to the router.

To be clear, the machine is connected over ethernet on the interface that I'm trying to change, but it seems like ASDM could/should be smart enough to handle that. Does it not?

Edit: In response to @Alex questions below. When I start out, my machine has IP, and the inside interface of the ASA has When I work through the wizard, I am setting the inside interface of the ASA to, and setting up a DHCP address pool of However I don't ever seem to be able to get an IP address from DHCP for my machine in the 10.x subnet.

share|improve this question

I typically kill the internal DHCP server on the ASA when I do this. The issue is that the DHCP server's pool belongs to the default 192.168.x.x subnet that the ASA comes from the factory with. This discrepancy is what causes the startup wizard to fail.

You can unconfigure the DHCP service and try again.

I usually give myself telnet access to the ASA in the GUI... and work from there.

share|improve this answer
Not sure I understand, I'm changing the DHCP pool configuration as part of the wizard... – brooks94 Nov 26 '12 at 19:40
Yeah, you'll have to decouple the two. Setup DHCP after you get the IP range where up want. I'd give you a walkthrough, but I don't have any plain ASA 5505's available now. – ewwhite Nov 26 '12 at 20:14
I'm in the same position (trying to change internal to a new address, and then can't connect) but I DO get DHCP address on my pc in the new local range, so I doubt the issue here is DHCP... Just changing it from to prevents ASDM connection. But the PC picks up a address via DHCP. – James Newton Jan 20 at 22:51

Is the IP of the workstation you are connecting from still part of the DHCP pool after the changes you are trying to apply?

Actually, before you make the changes, what are the IP adresses of both the ASA and the Workstation?

If you are really stuck because of a catch-22 situation, you might want to setup a management interface on the ASA and give it an IP that is available in your network.

You will then be able to reach the ASA on that IP.

There is a good example of how to first setup a ASA 5505 here, it's in CLI but I'm pretty sure you can catch the drift...

If you do not have the option of a management interface, I think you might have to use the console port and use the CLI instead.

share|improve this answer
Please see comments above. Also I have tried your suggestion of a management interface, and was told that the license I have does not support additional interfaces. – brooks94 Nov 26 '12 at 20:22
Did you try setting the IP of the ASA first ( then setting your workstation IP manually to And then change the DHCP pool? – Alex Nov 26 '12 at 20:27
THANK YOU ALEX! The setup instructions in your link worked for me, with a few slight changes, which I've documented at: – James Newton Jan 21 at 19:11

you can do factory reset from the cli

config factory-default 192.168.x.x

share|improve this answer
That does change the ip, but then ASDM will not respond on the new IP address. Not sure why, but see answer from Alex below. – James Newton Jan 21 at 19:10

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.