Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to set up a new 5505 for the first time. I am not a network admin, so I'm using the graphical tool that comes with it, ASDM. One of the things I am trying to do is change the subnet used by the "internal" network to 10.0.0.x. In the startup wizard, I change:

  • the internal interface's ip address to 10.0.0.1
  • the dhcp server to serve ip addresses in 10.0.0.10-40
  • allow incoming https/ASDM connections on internal's 10.0.0.x subnet

Then when I click "go" at the end of the wizard, a modal dialog pops up that says "sending command(s) to router" or somesuch. That dialog never goes away. Further, it seems like the configuration never gets applied. I can't renew the DHCP lease on the machine connected to the router.

To be clear, the machine is connected over ethernet on the interface that I'm trying to change, but it seems like ASDM could/should be smart enough to handle that. Does it not?

Edit: In response to @Alex questions below. When I start out, my machine has IP 192.168.1.5, and the inside interface of the ASA has 192.168.1.1. When I work through the wizard, I am setting the inside interface of the ASA to 10.0.0.1, and setting up a DHCP address pool of 10.0.0.10-40. However I don't ever seem to be able to get an IP address from DHCP for my machine in the 10.x subnet.

share|improve this question

3 Answers 3

I typically kill the internal DHCP server on the ASA when I do this. The issue is that the DHCP server's pool belongs to the default 192.168.x.x subnet that the ASA comes from the factory with. This discrepancy is what causes the startup wizard to fail.

You can unconfigure the DHCP service and try again.

I usually give myself telnet access to the ASA in the GUI... and work from there.

share|improve this answer
    
Not sure I understand, I'm changing the DHCP pool configuration as part of the wizard... –  brooks94 Nov 26 '12 at 19:40
    
Yeah, you'll have to decouple the two. Setup DHCP after you get the IP range where up want. I'd give you a walkthrough, but I don't have any plain ASA 5505's available now. –  ewwhite Nov 26 '12 at 20:14

you can do factory reset from the cli

config factory-default 192.168.x.x 255.255.255.0

share|improve this answer

Is the IP of the workstation you are connecting from still part of the DHCP pool after the changes you are trying to apply?

Actually, before you make the changes, what are the IP adresses of both the ASA and the Workstation?

If you are really stuck because of a catch-22 situation, you might want to setup a management interface on the ASA and give it an IP that is available in your network.

You will then be able to reach the ASA on that IP.

There is a good example of how to first setup a ASA 5505 here, it's in CLI but I'm pretty sure you can catch the drift...

If you do not have the option of a management interface, I think you might have to use the console port and use the CLI instead.

share|improve this answer
    
Please see comments above. Also I have tried your suggestion of a management interface, and was told that the license I have does not support additional interfaces. –  brooks94 Nov 26 '12 at 20:22
    
Did you try setting the IP of the ASA first (10.0.0.1/24) then setting your workstation IP manually to 10.0.0.2/24? And then change the DHCP pool? –  Alex Nov 26 '12 at 20:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.