Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want setup socks server on my localhost which forward all http traffic on my remote server for bypass firewall rules at my work net. And so I start it as usually

sudo ssh -C2qTnN -D localhost:8080 -i myAWSKey.pem ubuntu@someserver.com

And set proxy settings in my browser. But then I try going to everywhere it's raise error "The connection was reset". Why it's doesn't work maybe Amazone denied this feature?

p.s and yes I have option AllowTcpForwarding yes at my server's sshd_config

my host system ubuntu 12.10 and server is ubuntu 12.04

share|improve this question

closed as off topic by Sven, Magellan, Ward, sysadmin1138 Nov 29 '12 at 3:51

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
What proxy settings have you set in your browser, exactly? –  MadHatter Nov 27 '12 at 7:21
    
Ssh -D option enables socks proxy (common port is 1080). 8080 may suggest that you mixed http and socks proxy types. –  kupson Nov 27 '12 at 7:36
    
@MadHatter I use firefox and setuo localhost 8080 for all services –  Denis Nov 27 '12 at 7:41

1 Answer 1

up vote 2 down vote accepted

The proxy built into ssh is a SOCKS proxy, not an HTTP or any other kind of proxy. That said, it's capable of proxying http, as well as just about anything else TCP-based, for a SOCKS-capable client. Firefox is such a client.

You need to make sure that in your browser proxy settings, the entries for HTTP, SSL and FTP proxy are blank; only SOCKS proxy should be host localhost and port 8080.

share|improve this answer
    
Yeah, its work, i looks like a full idiot right now )) –  Denis Nov 27 '12 at 11:14
    
<GRIN> not to worry, you'd look an even bigger idiot if you hadn't asked! –  MadHatter Nov 27 '12 at 11:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.